summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 729badf6da..22d587b29b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -10958,6 +10958,32 @@ logging.")
symbols in the style of Sublime Text, VSCode, @code{IntelliJ} IDEA et al.")
(license license:expat)))
+(define-public go-github-com-saracen-walker
+ (package
+ (name "go-github-com-saracen-walker")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/saracen/walker")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17i2zrbcp0zgwfgap555pk358wpqfa8qj8pmgwhjkzwd77nyl77g"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/saracen/walker"))
+ (inputs
+ (list go-golang-org-x-sync))
+ (home-page "https://github.com/saracen/walker")
+ (synopsis "Faster, parallel version of Go's filepath.Walk")
+ (description
+ "The @code{walker} function is a faster, parallel version, of
+@code{filepath.Walk}")
+ (license license:expat)))
+
(define-public go-github-com-satori-go-uuid
(package
(name "go-github-com-satori-go-uuid")