summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm28
1 files changed, 19 insertions, 9 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 08fa1570d6..22fef794b0 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2017, 2020 Leo Famulari <[email protected]>
;;; Copyright © 2017 Petter <[email protected]>
;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <[email protected]>
-;;; Copyright © 2018, 2019 Marius Bakke <[email protected]>
+;;; Copyright © 2018, 2019, 2022 Marius Bakke <[email protected]>
;;; Copyright © 2018 Björn Höfling <[email protected]>
;;; Copyright © 2019 Mathieu Othacehe <[email protected]>
;;; Copyright © 2020 Fredrik Salomonsson <[email protected]>
@@ -91,7 +91,7 @@
(define-public libgpg-error
(package
(name "libgpg-error")
- (version "1.42")
+ (version "1.45")
(source
(origin
(method url-fetch)
@@ -99,7 +99,7 @@
version ".tar.bz2"))
(sha256
(base32
- "08syj8mlarww8mh8x3s0x6hjqbnxp2lkg3hab57qqpv1dh7yf1zw"))))
+ "09haz1kk48b8q0hd58g98whylah0fp121yfgjms7pzsbzgj8w3sp"))))
(build-system gnu-build-system)
(arguments
(if (%current-target-system)
@@ -142,7 +142,7 @@
(_ #t)))
(#t #t)))))))
'()))
- (native-inputs `(("gettext" ,gettext-minimal)))
+ (native-inputs (list gettext-minimal))
(home-page "https://gnupg.org")
(synopsis "Library of error values for GnuPG components")
(description
@@ -157,14 +157,14 @@ Daemon and possibly more in the future.")
(define-public libgcrypt
(package
(name "libgcrypt")
- (version "1.8.8")
+ (version "1.10.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/libgcrypt/libgcrypt-"
version ".tar.bz2"))
(sha256
(base32
- "1xasrh9zxhgj2n5n8dvpzbwn1mzpmlzy270xhbq2gl8xk2xy4pc9"))))
+ "1pp9zyx02bzgzjzldxf0mx9kp3530xgaaqcz4n2cv100ddaaw57g"))))
(build-system gnu-build-system)
(propagated-inputs
`(("libgpg-error-host" ,libgpg-error)))
@@ -176,10 +176,20 @@ Daemon and possibly more in the future.")
;; 'configure' uses 'gpg-error-config' to determine the '-L' flag, and
;; the 'gpg-error-config' it runs is the native one---i.e., the wrong one.
`(#:configure-flags
- (list (string-append "--with-gpg-error-prefix="
+ (list (string-append "--with-libgpg-error-prefix="
(assoc-ref %build-inputs "libgpg-error-host"))
- ;; When cross-compiling, _gcry_mpih_lshift etc are undefined
- ,@(if (%current-target-system) '("--disable-asm")
+ ,@(if (%current-target-system)
+ ;; When cross-compiling, _gcry_mpih_lshift etc are undefined.
+ `("--disable-asm"
+ ;; libgcrypt is transitioning from gpg-error-config to
+ ;; gpgrt-config, and in the process the
+ ;; --with-libgpg-error-config prefix defined above is
+ ;; not respected. See <https://dev.gnupg.org/T5365>.
+ ;; TODO: transition to pkg-config instead of these scripts.
+ (string-append "ac_cv_path_GPGRT_CONFIG="
+ (assoc-ref %build-inputs
+ "libgpg-error-host")
+ "/bin/gpgrt-config"))
'()))))
(outputs '("out" "debug"))
(home-page "https://gnupg.org/")