summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm67
1 files changed, 29 insertions, 38 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 1935e73ab7..55759f47ff 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <[email protected]>
;;; Copyright © 2014, 2015 Mark H Weaver <[email protected]>
;;; Copyright © 2018 Efraim Flashner <[email protected]>
-;;; Copyright © 2021 Marius Bakke <[email protected]>
+;;; Copyright © 2021, 2022 Marius Bakke <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,61 +25,52 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages libsigsegv)
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix build-system gnu))
(define-public gawk
(package
(name "gawk")
- (version "5.1.0")
+ (version "5.1.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gawk/gawk-" version
".tar.xz"))
(sha256
- (base32 "1gc2cccqy1x1bf6rhwlmd8q7dz7gnam6nwgl38bxapv6qm5flpyg"))))
+ (base32 "18kybw47fb1sdagav7aj95r9pp09r5gm202y3ahvwjw9dqw2jxnq"))))
(build-system gnu-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'configure 'set-shell-file-name
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Refer to the right shell.
- (let ((bash (assoc-ref inputs "bash")))
- (substitute* "io.c"
- (("/bin/sh")
- (string-append bash "/bin/sh")))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'set-shell-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Refer to the right shell.
+ (let ((/bin/sh (search-input-file inputs "bin/sh")))
+ (substitute* "io.c"
+ (("/bin/sh") /bin/sh))
- ;; When cross-compiling, remove dependencies on the
- ;; `check-for-shared-lib-support' target, which tries
- ;; to run the cross-built `gawk'.
- ,@(if (%current-target-system)
- '((substitute* "extension/Makefile.in"
+ ;; When cross-compiling, remove dependencies on the
+ ;; `check-for-shared-lib-support' target, which tries
+ ;; to run the cross-built `gawk'.
+ #$@(if (%current-target-system)
+ '((substitute* "extension/Makefile.in"
(("^.*: check-for-shared-lib-support" match)
(string-append "### " match))))
- '()))))
+ '()))))
- (add-before 'check 'adjust-test-infrastructure
- (lambda _
- ;; Remove dependency on 'more' (from util-linux), which
- ;; would needlessly complicate bootstrapping.
- (substitute* "test/Makefile"
- (("\\| more") ""))
+ (add-before 'check 'adjust-test-infrastructure
+ (lambda _
+ ;; Remove dependency on 'more' (from util-linux), which
+ ;; would needlessly complicate bootstrapping.
+ (substitute* "test/Makefile"
+ (("\\| more") ""))
- ;; Silence a warning from bash about not being able
- ;; to change to an ISO-8859-1 locale. The test itself
- ;; works fine, but newer versions of bash give a
- ;; locale warning which mangles the test output.
- (substitute* "test/localenl.sh"
- (("for LC_ALL in")
- "for LC in")
- (("export LC_ALL\n")
- "export LC_ALL=$LC 2>/dev/null\n"))
-
- ;; Adjust the shebang in that file since it is then diff'd
- ;; against the actual test output.
- (substitute* "test/watchpoint1.ok"
- (("#! /usr/bin/gawk")
- (string-append "#!" (which "gawk")))))))))
+ ;; Adjust the shebang in that file since it is then diff'd
+ ;; against the actual test output.
+ (substitute* "test/watchpoint1.ok"
+ (("#! /usr/bin/gawk")
+ (string-append "#!" (which "gawk")))))))))
(inputs (list libsigsegv
;; Use the full-fledged Bash package, otherwise the test suite