summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm91
1 files changed, 86 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b25133db78..8dd08844ee 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4938,9 +4938,9 @@ fight against their plot and save his fellow rabbits from slavery.")
(home-page "https://play0ad.com")
(license (list (license:fsdg-compatible
"http://tavmjong.free.fr/FONTS/ArevCopyright.txt"
- (license:license-comment
- (package-license font-bitstream-vera)))
- (package-license font-bitstream-vera)
+ "Similar to the license of the Bitstream Vera fonts.")
+ (license:fsdg-compatible
+ "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts")
license:cc-by-sa3.0
license:expat
license:gfl1.0
@@ -6812,7 +6812,7 @@ where the player draws runes in real time to effect the desired spell.")
(define-public edgar
(package
(name "edgar")
- (version "1.31")
+ (version "1.32")
(source
(origin
(method url-fetch)
@@ -6820,7 +6820,7 @@ where the player draws runes in real time to effect the desired spell.")
(string-append "https://github.com/riksweeney/edgar/releases/download/"
version "/edgar-" version "-1.tar.gz"))
(sha256
- (base32 "0i4851ci8a86ql4bhdq3xdfmf4b9z5zrd4xpc6vhi06697zgm13i"))))
+ (base32 "12lam6qcscc5ima1w2ksd1cvsvxbd17h6mqkgsqpzx8ap43p2r5p"))))
(build-system gnu-build-system)
(arguments '(#:tests? #f ; there are no tests
#:make-flags
@@ -7818,3 +7818,84 @@ remake of that series or any other game.")
the AlphaGo Zero paper. The current best network weights file for the engine
can be downloaded from @url{https://zero.sjeng.org/best-network}.")
(license license:gpl3+)))
+
+(define-public q5go
+ (package
+ (name "q5go")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bernds/q5Go.git")
+ (commit (string-append "q5go-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gdlfqcqkqv7vph3qwq78d0qz6dhmdsranxq9bmixiisbzkqby31"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtsvg" ,qtsvg)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-configure-script
+ (lambda _
+ ;; Bypass the unavailable qtchooser program.
+ (substitute* "configure"
+ (("test -z \"QTCHOOSER\"")
+ "false")
+ (("qtchooser -run-tool=(.*) -qt=qt5" _ command)
+ command))
+ #t))
+ (add-after 'unpack 'fix-paths
+ (lambda _
+ (substitute* '("src/pics/Makefile.in"
+ "src/translations/Makefile.in")
+ (("\\$\\(datadir\\)/qGo/")
+ "$(datadir)/q5go/"))
+ #t))
+ (add-after 'install 'install-desktop-file
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (apps (string-append out "/share/applications"))
+ (pics (string-append out "/share/q5go/pics")))
+ (delete-file-recursively (string-append out "/share/applnk"))
+ (delete-file-recursively (string-append out "/share/mimelnk"))
+ (install-file "../source/src/pics/Bowl.ico" pics)
+ (mkdir-p apps)
+ (with-output-to-file (string-append apps "/q5go.desktop")
+ (lambda _
+ (format #t
+ "[Desktop Entry]~@
+ Name=q5go~@
+ Exec=~a/bin/q5go~@
+ Icon=~a/Bowl.ico~@
+ Categories=Game;~@
+ Comment=Game of Go~@
+ Comment[de]=Spiel des Go~@
+ Comment[eo]=Goo~@
+ Comment[es]=Juego de Go~@
+ Comment[fr]=Jeu de Go~@
+ Comment[ja]=囲碁~@
+ Comment[ko]=바둑~@
+ Comment[zh]=围棋~@
+ Terminal=false~@
+ Type=Application~%"
+ out pics))))
+ #t)))))
+ (synopsis "Qt GUI to play the game of Go")
+ (description
+ "This a tool for Go players which performs the following functions:
+@itemize
+@item SGF editor,
+@item Analysis frontend for Leela Zero (or compatible engines),
+@item GTP interface (to play against an engine),
+@item IGS client (to play on the internet),
+@item Export games to a variety of formats.
+@end itemize")
+ (home-page "https://github.com/bernds/q5Go")
+ (license license:gpl2+)))