summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm76
1 files changed, 44 insertions, 32 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8108b8f6d1..9f620dc004 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2810,44 +2810,49 @@ ontinuous-time and discret-time expressions.")
".src.tar.gz"))
(sha256
(base32
- "0n83szr88h8snccjrslr96mgw3f65x3sq726n6x5vxp5wybw4f6r"))))
+ "0n83szr88h8snccjrslr96mgw3f65x3sq726n6x5vxp5wybw4f6r"))
+ (patches
+ ;; Upstream patches to make version 2021.01 build with recent versions
+ ;; of boost and cgal.
+ (search-patches "openscad-with-cgal-5.3.patch"
+ "openscad-with-cgal-5.4.patch"
+ "openscad-fix-boost-join.patch"))))
(build-system cmake-build-system)
(inputs
- `(("boost" ,boost)
- ("cgal" ,cgal)
- ("double-conversion" ,double-conversion)
- ("eigen" ,eigen)
- ("fontconfig" ,fontconfig)
- ("glew" ,glew)
- ("gmp" ,gmp)
- ("harfbuzz" ,harfbuzz)
- ("lib3mf" ,lib3mf)
- ("libxml2" ,libxml2)
- ("libzip" ,libzip)
- ("mpfr" ,mpfr)
- ("opencsg" ,opencsg)
- ("qscintilla" ,qscintilla)
- ("qtbase" ,qtbase-5)
- ("qtmultimedia-5" ,qtmultimedia-5)))
+ (list boost
+ cgal
+ double-conversion
+ eigen
+ fontconfig
+ glew
+ gmp
+ harfbuzz
+ lib3mf
+ libxml2
+ libzip
+ mpfr
+ opencsg
+ qscintilla
+ qtbase-5
+ qtmultimedia-5))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)
- ("which" ,which)
- ;; the following are only needed for tests
- ("imagemagick" ,imagemagick)
- ("ps" ,procps)
- ("python" ,python)
- ("xvfb" ,xorg-server-for-tests)))
+ (list bison
+ flex
+ gettext-minimal
+ pkg-config
+ which
+ ;; the following are only needed for tests
+ imagemagick
+ procps
+ python
+ xorg-server-for-tests))
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(invoke "qmake"
- (string-append "PREFIX=" (assoc-ref outputs "out")))
- #t))
+ (string-append "PREFIX=" (assoc-ref outputs "out")))))
(replace 'check
(lambda _
(with-directory-excursion "tests"
@@ -2873,12 +2878,19 @@ ontinuous-time and discret-time expressions.")
"cgalpngtest_nef3_broken"
"opencsgtest_nef3_broken"
"csgpngtest_nef3_broken"
- "throwntogethertest_nef3_broken")
+ "throwntogethertest_nef3_broken"
+
+ ;; FIXME: Tests probably broken by the patches allowing
+ ;; to build with recent cgal versions.
+ "cgalpngtest_polyhedron-nonplanar-tests"
+ "csgpngtest_polyhedron-nonplanar-tests"
+ "monotonepngtest_polyhedron-nonplanar-tests"
+ "cgalstlcgalpngtest_polyhedron-nonplanar-tests"
+ "cgalbinstlcgalpngtest_polyhedron-nonplanar-tests")
"|")))
;; strip python test files since lib dir ends up in out/share
(for-each delete-file
- (find-files "libraries/MCAD" ".*\\.py"))
- #t)))))
+ (find-files "libraries/MCAD" ".*\\.py")))))))
(synopsis "Script-based 3D modeling application")
(description
"OpenSCAD is a 3D Computer-aided Design (CAD) application. Unlike an