summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm34
1 files changed, 12 insertions, 22 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 17a69bcd1c..242c531652 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -619,14 +619,14 @@ standard library.")
(define-public python-pytest
(package
(name "python-pytest")
- (version "3.5.0")
+ (version "3.6.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest" version))
(sha256
(base32
- "1q832zd07zak2lyxbycxjydh0jp7y3hvawjqzlvra6aghz8r3r7s"))))
+ "0h85kzdi5pfkz9v0z8xyrsj1rvnmyyjpng7cran28jmnc41w27il"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -644,7 +644,8 @@ standard library.")
line)))
#t)))))
(propagated-inputs
- `(("python-attrs" ,python-attrs-bootstrap)
+ `(("python-atomicwrites" ,python-atomicwrites)
+ ("python-attrs" ,python-attrs-bootstrap)
("python-more-itertools" ,python-more-itertools)
("python-pluggy" ,python-pluggy)
("python-py" ,python-py)
@@ -693,14 +694,14 @@ and many external plugins.")
(define-public python-pytest-cov
(package
(name "python-pytest-cov")
- (version "2.4.0")
+ (version "2.5.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-cov" version))
(sha256
(base32
- "03c2qc42r4bczyw93gd7n0qi1h1jfhw7fnbhi33c3vp1hs81gm2k"))))
+ "0bbfpwdh9k3636bxc88vz9fa7vf4akchgn513ql1vd0xy4n7bah3"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -729,26 +730,15 @@ supports coverage of subprocesses.")
(define-public python-pytest-runner
(package
(name "python-pytest-runner")
- (version "2.11.1")
+ (version "4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-runner" version))
(sha256
(base32
- "1cw978kqqcq916b9gfns1qjqvg33c5ail5jhw9054dsynkm32flq"))))
+ "1gkpyphawxz38ni1gdq1fmwyqcg02m7ypzqvv46z06crwdxi2gyj"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; The fancy way of setting the version with setuptools_scm does not
- ;; seem to work here.
- (add-after 'unpack 'set-version
- (lambda _
- (substitute* "docs/conf.py"
- (("version = setuptools_scm\\.get_version\\(root='\\.\\.')")
- (string-append "version = \"" ,version "\"")))
- #t)))))
(native-inputs
`(("python-pytest" ,python-pytest-bootstrap)
("python-setuptools-scm" ,python-setuptools-scm)))
@@ -765,14 +755,14 @@ supports coverage of subprocesses.")
(define-public python-pytest-mock
(package
(name "python-pytest-mock")
- (version "1.6.3")
+ (version "1.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-mock" version))
(sha256
(base32
- "075v7b2wm5f839r1a30n21wfk5rfqp3d05q7zb9jlb2wmxki23cj"))))
+ "1h6lgpmsvs9s8j2s80v06f9f3iaw1n1rc51mbrxk1f12sw4q56nq"))))
(build-system python-build-system)
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)))
@@ -1421,13 +1411,13 @@ normally the case.")
(define-public python-hypothesis
(package
(name "python-hypothesis")
- (version "3.52.0")
+ (version "3.66.6")
(source (origin
(method url-fetch)
(uri (pypi-uri "hypothesis" version))
(sha256
(base32
- "0g54cypfi5qj6cgxfr7l1nb41r1cqhhngx4qxn4ga9h720rcsbr8"))))
+ "0jlcbnirj5ndv4gvb3rmydligljn1alim9d4dk377188y09iwl5k"))))
(build-system python-build-system)
(native-inputs
`(("python-flake8" ,python-flake8)