summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm45
1 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 118f25ba09..480e80d65d 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2017, 2018 Mark H Weaver <[email protected]>
;;; Copyright © 2016 David Thompson <[email protected]>
;;; Copyright © 2017 Nikita <[email protected]>
-;;; Copyright © 2017, 2019, 2021 Efraim Flashner <[email protected]>
+;;; Copyright © 2017, 2019, 2021, 2022 Efraim Flashner <[email protected]>
;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2018 Ricardo Wurmus <[email protected]>
;;; Copyright © 2019 Pierre-Moana Levesque <[email protected]>
@@ -324,14 +324,14 @@ output is indexed in many ways to simplify browsing.")
(define-public automake
(package
(name "automake")
- (version "1.16.3")
+ (version "1.16.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/automake/automake-"
version ".tar.xz"))
(sha256
(base32
- "0fmz2fhmzcpacnprl5msphvaflwiy0hvpgmqlgfny72ddijzfazz"))
+ "0v8kbw4fan7apbjwziylyjl5z708w452r5q6kpafcmssi04wryl0"))
(patches
(search-patches "automake-skip-amhello-tests.patch"))))
(build-system gnu-build-system)
@@ -451,25 +451,26 @@ Makefile, simplifying the entire process for the developer.")
(define-public libtool
(package
(name "libtool")
- (version "2.4.6")
+ (version "2.4.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libtool/libtool-"
version ".tar.xz"))
(sha256
(base32
- "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
+ "0pb3l4x37k6fj1lwnpzws55gi3pxl0hx56jm4bzmbrkw0mzj2zsg"))
(patches (search-patches "libtool-skip-tests2.patch"))))
(build-system gnu-build-system)
(propagated-inputs (list m4))
- (native-inputs `(("m4" ,m4)
- ("perl" ,perl)
- ;; XXX: this shouldn't be necessary, but without it test
- ;; 102 fails because it cannot find ltdl/libltdl.la.
- ("libltdl" ,libltdl)
- ("help2man" ,help2man) ;because we modify ltmain.sh
- ("automake" ,automake) ;some tests rely on 'aclocal'
- ("autoconf" ,autoconf-wrapper))) ;others on 'autom4te'
+ (native-inputs
+ (list m4
+ perl
+ ;; XXX: this shouldn't be necessary, but without it test
+ ;; 102 fails because it cannot find ltdl/libltdl.la.
+ libltdl
+ help2man ; because we modify ltmain.sh
+ automake ; some tests rely on 'aclocal'
+ autoconf-wrapper)) ; others on 'autom4te'
(arguments
`(;; Libltdl is provided as a separate package, so don't install it here.
@@ -485,18 +486,19 @@ Makefile, simplifying the entire process for the developer.")
#:phases
(modify-phases %standard-phases
(add-before 'check 'pre-check
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (lambda* (#:key inputs native-inputs parallel-tests? #:allow-other-keys)
;; Run the test suite in parallel, if possible.
(setenv "TESTSUITEFLAGS"
(string-append
"-j"
- (number->string (parallel-job-count))))
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1")))
;; Patch references to /bin/sh.
(let ((bash (assoc-ref (or native-inputs inputs) "bash")))
(substitute* "tests/testsuite"
(("/bin/sh")
- (string-append bash "/bin/sh")))
- #t)))
+ (string-append bash "/bin/sh"))))))
;; These files may be copied into source trees by libtoolize,
;; therefore they must not point to store file names that would be
;; leaked with tarballs generated by make dist.
@@ -508,8 +510,7 @@ Makefile, simplifying the entire process for the developer.")
(format #t "restoring shebang on `~a'~%" file)
(substitute* file
(("^#!.*/bin/sh") "#!/bin/sh")))
- (find-files dir ".*"))
- #t))))))
+ (find-files dir))))))))
(synopsis "Generic shared library support tools")
(description
@@ -585,20 +586,20 @@ configuration in nearly all GNU packages (and many others).")
;; Libtool's extensive test suite isn't run.
(package
(name "libltdl")
- (version "2.4.6")
+ (version "2.4.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libtool/libtool-"
version ".tar.xz"))
(sha256
(base32
- "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))))
+ "0pb3l4x37k6fj1lwnpzws55gi3pxl0hx56jm4bzmbrkw0mzj2zsg"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-ltdl-install") ;really install it
#:phases (modify-phases %standard-phases
(add-before 'configure 'change-directory
- (lambda _ (chdir "libltdl") #t)))))
+ (lambda _ (chdir "libltdl"))))))
(synopsis "System-independent dlopen wrapper of GNU libtool")
(description (package-description libtool))