summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 92644c4f62..6743223987 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Nicolas Goaziou <[email protected]>
;;; Copyright © 2014, 2018 Mark H Weaver <[email protected]>
;;; Copyright © 2016, 2018, 2019, 2021 Ricardo Wurmus <[email protected]>
-;;; Copyright © 2017, 2020 Efraim Flashner <[email protected]>
+;;; Copyright © 2017, 2020, 2021 Efraim Flashner <[email protected]>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2017 Marius Bakke <[email protected]>
;;; Copyright © 2017, 2019, 2021 Eric Bavier <[email protected]>
@@ -248,8 +248,8 @@ the real span of the lattice.")
"095s7vdlsxmxa0n0l1a082m6gjaypqfqkaj99z8j7dx0ji89hy8n"))))
(build-system gnu-build-system)
(native-inputs
- `(("texlive" ,(texlive-union
- (list texlive-amsfonts/patched)))))
+ `(("texlive" ,(texlive-updmap.cfg
+ (list texlive-amsfonts)))))
(inputs `(("gmp" ,gmp)
("libx11" ,libx11)
("perl" ,perl)
@@ -702,12 +702,14 @@ binary.")
("ed" ,ed)
("flex" ,flex)
("texinfo" ,texinfo)))
+ (inputs
+ `(("readline" ,readline)))
(arguments
'(#:configure-flags
(list "--with-readline")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autogen
+ (replace 'bootstrap
(lambda _
(invoke "autoreconf" "-vif"))))))
(home-page "https://www.gnu.org/software/bc/")