summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 4daaddcfec..8f4a4cd41e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -12,10 +12,10 @@
;;; Copyright © 2016, 2017 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Peter Feigl <[email protected]>
;;; Copyright © 2016 John J. Foerch <[email protected]>
-;;; Coypright © 2016, 2017 ng0 <[email protected]>
-;;; Coypright © 2016 Tobias Geerinckx-Rice <[email protected]>
-;;; Coypright © 2016 John Darrington <[email protected]>
-;;; Coypright © 2017 Ben Sturmfels <[email protected]>
+;;; Copyright © 2016, 2017 ng0 <[email protected]>
+;;; Copyright © 2016 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2016 John Darrington <[email protected]>
+;;; Copyright © 2017 Ben Sturmfels <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2060,11 +2060,15 @@ Intel DRM Driver.")
(uri (pypi-uri "Fabric" version))
(sha256
(base32
- "1z17hw0yiqp1blq217zxkg2jzkv8qd79saqhscgsw14mwlcqpwd0"))))
+ "1z17hw0yiqp1blq217zxkg2jzkv8qd79saqhscgsw14mwlcqpwd0"))
+ (patches (search-patches "fabric-tests.patch"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ;XXX: Tests attempt to download Python "fudge" package.
- #:python ,python-2)) ;Python 2 only
+ `(#:python ,python-2)) ;Python 2 only
+ (native-inputs
+ `(("python2-fudge" ,python2-fudge) ; Requires < 1.0
+ ("python2-jinja2" ,python2-jinja2) ; Requires < 3.0
+ ("python2-nose" ,python2-nose))) ; Requires < 2.0
(propagated-inputs
;; Required upgrading python-paramiko 1.17.4 to fix an incompatibility
;; between python-paramiko and newer python-pycrypto. Without this, the