summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/elf.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 74bc62a300..7b769770f8 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 Michael Rohleder <[email protected]>
;;; Copyright © 2021 Leo Le Bouter <[email protected]>
;;; Copyright © 2021 Maxime Devos <[email protected]>
+;;; Copyright © 2022 Daniel Maksymow <[email protected]>
;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <[email protected]>
;;; Copyright © 2024 Zheng Junjie <[email protected]>
;;;
@@ -35,7 +36,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
- #:use-module ((guix licenses) #:select (gpl3+ lgpl3+ lgpl2.0+ lgpl2.1 gpl2 bsd-2))
+ #:use-module ((guix licenses) #:select (gpl2+ gpl3+ lgpl3+ lgpl2.0+ lgpl2.1 gpl2 bsd-2))
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
@@ -50,6 +51,28 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public chrpath
+ (package
+ (name "chrpath")
+ (version "0.18")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/pere/chrpath")
+ (commit (string-append "release_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0n7fp6xm660m8inaadlblh7zr8izyc3x39bfdqi6rj1kn0vmzra6"))))
+ (build-system gnu-build-system)
+ (native-inputs (list automake autoconf))
+ (home-page "https://codeberg.org/pere/chrpath")
+ (synopsis "Utility for editing the RPATH or RUNPATH of ELF binaries")
+ (description "@code{chrpath} allows listing, changing or removing the
+dynamic library load path (RPATH and RUNPATH) of compiled programs and
+libraries.")
+ (license gpl2+)))
+
(define-public elfutils
(package
(name "elfutils")