summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/compression.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 73a35030e9..fbbc32197a 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015, 2016 Ricardo Wurmus <[email protected]>
;;; Copyright © 2015 Leo Famulari <[email protected]>
;;; Copyright © 2015 Jeff Mickey <[email protected]>
-;;; Copyright © 2015, 2016 Efraim Flashner <[email protected]>
+;;; Copyright © 2015, 2016, 2017 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Ben Woodcroft <[email protected]>
;;; Copyright © 2016 Danny Milosavljevic <[email protected]>
;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <[email protected]>
@@ -1034,11 +1034,12 @@ functionality in a C++ iostream.")
(_ " -DNOJIT")))
;; These should be safe, lowest-common-denominator instruction sets,
;; allowing for some optimisation while remaining reproducible.
- (string-append "CXXFLAGS=-O3 -mtune=generic -DNDEBUG"
+ (string-append "CXXFLAGS=-O3 -DNDEBUG"
,(match (or (%current-target-system)
(%current-system))
- ("x86_64-linux" " -march=nocona")
- ("i686-linux" " -march=i686")
+ ("x86_64-linux" " -march=nocona -mtune=generic")
+ ("i686-linux" " -march=i686 -mtune=generic")
+ ("armhf-linux" " -mtune=generic-armv7-a")
(_ "")))
(string-append "PREFIX="
(assoc-ref %outputs "out")))))