summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/libedit.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/libedit.scm b/gnu/packages/libedit.scm
index f04d3aafe4..252f8a4966 100644
--- a/gnu/packages/libedit.scm
+++ b/gnu/packages/libedit.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019 Gábor Boskovits <[email protected]>
;;; Copyright © 2020 Giacomo Leidi <[email protected]>
+;;; Copyright © 2024 Janneke Nieuwenhuizen <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,8 +22,10 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages libedit)
+ #:use-module (guix gexp)
#:use-module (guix licenses)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages ncurses))
@@ -39,6 +42,11 @@
(sha256
(base32 "0wch48nml28jj6ild889745dsg2agm7mpvrmbl1gi98nw6vjrf6v"))))
(build-system gnu-build-system)
+ (arguments
+ (if (and (%current-target-system) (target-x86-32?))
+ (list #:configure-flags
+ #~(list "CFLAGS=-g -O2 -Wno-incompatible-pointer-types"))
+ '()))
(inputs
(list ncurses))
(home-page "https://thrysoee.dk/editline/")