summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/astronomy.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ae1030b922..ce8a1291c4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3051,6 +3051,37 @@ semi-analytic models, to cosmological hydrodynamic simulations, and even
observationally-derived galaxy merger catalogs.")
(license license:expat)))
+(define-public python-lofar-h5plot
+ (package
+ (name "python-lofar-h5plot")
+ (version "2.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lofar_h5plot" version))
+ (sha256
+ (base32 "0gxri18iqsw1l5zxn40475zj34h5nn1bscfrhkc739vpqjmj60hz"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; no tests provided
+ (native-inputs
+ (list python-cython-3
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-losoto
+ python-matplotlib
+ python-numpy
+ python-pyqt
+ python-pyqt5-sip))
+ (home-page "https://github.com/tikk3r/lofar-h5plot")
+ (synopsis "GUI for plotting H5Parms produced during LOFAR calibration")
+ (description
+ "H5plot is a small GUI to view the solutions in an H5parm interactively.
+It is a spiritual successor to @code{ParmDBplot} for quickly reviewing gain
+solutions generated by NDPPP.")
+ (license license:gpl3)))
+
(define-public python-losoto
(package
(name "python-losoto")