summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6622edc447..7285313ebb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8566,7 +8566,11 @@ users.")
((".*test-link-linux.*") "")
((".*test-lldp.*") "")
((".*test-route-linux.*") "")
- ((".*test-tc-linux.*") ""))))
+ ((".*test-tc-linux.*") ""))
+ (substitute* "src/libnm-client-impl/meson.build"
+ ;; Note: printenv results in bogus newline, that isn't stripped
+ (("run_command\\('printenv', '([^']*)',[^\n]*" all var)
+ (string-append "'" (or (getenv var) "") "'")))))
(add-before 'check 'pre-check
(lambda _
;; For the missing /etc/machine-id.