summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-check.scm2
-rw-r--r--gnu/packages/golang-compression.scm2
-rw-r--r--gnu/packages/golang-crypto.scm2
-rw-r--r--gnu/packages/golang-web.scm2
-rw-r--r--gnu/packages/golang-xyz.scm10
5 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 6c789bd652..964f62a096 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -2481,7 +2481,7 @@ advanced Go linter.")
(home-page "https://gitlab.com/cznic/ccorpus2")
(synopsis "Continuation of ccorpus using @code{embed.FS}")
(description
- "This packge provides a test corpus of C code.")
+ "This package provides a test corpus of C code.")
(license license:bsd-3)))
(define-public go-mvdan-cc-unparam
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index 2628036c31..46464621e4 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -242,7 +242,7 @@ time, as otherwise the internal gzip library will likely be faster.")
go-github-com-ulikunitz-xz
go-github-com-xi2-xz))
(home-page "https://github.com/mholt/archiver")
- (synopsis "Multi format archiver Golang library and CLI commad")
+ (synopsis "Multi format archiver Golang library and CLI command")
(description
"Package archiver facilitates convenient, cross-platform, high-level
archival and compression operations for a variety of formats and compression
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index fa8c5e9529..0a72050250 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -2316,7 +2316,7 @@ https://code.google.com/p/go-crypt.")
(propagated-inputs
(list go-golang-org-x-sys))
(home-page "https://gitlab.com/yawning/bsaes")
- (synopsis "AES implementatin in Golang")
+ (synopsis "AES implementation in Golang")
(description
"The @code{bsaes} is a portable pure-Go constant time AES implementation
based on the code from @url{https://bearssl.org/,BearSSL}. On appropriate
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 74d9eafcc4..9e59f8353e 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -6821,7 +6821,7 @@ writer, as per specification:
@@url{https://www.haproxy.org/download/2.3/doc/proxy-protocol.txt}. It is to
be used in one of or both proxy clients and proxy servers that need to support
said protocol. Both protocol versions, 1 (text-based) and 2 (binary-based)
-are supported. @acronym{TLV, tag-length-value} parsers extensions comming with
+are supported. @acronym{TLV, tag-length-value} parsers extensions coming with
this library support AWS, Azure and GCP.")
(license license:asl2.0)))
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 947167ca9a..537b6ad31d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6455,7 +6455,7 @@ execution.")
(native-inputs
(list go-github-com-golangplus-testing-bootstrap))
(home-page "https://github.com/golangplus/bytes")
- (synopsis "Extention to Golang standard @code{bytes} library.")
+ (synopsis "Extension to Golang standard @code{bytes} library.")
(description
"Package bytesp is a plus to the standard @code{bytes} package.")
(license license:bsd-3)))
@@ -6746,7 +6746,7 @@ color (24-bit, RGB)
(synopsis "Golang file globbing library")
(description
"This package provides a filesystem glob API. It uses @code{gobwas/glob}
-underneath and returns only matching files or direcories, depending on the
+underneath and returns only matching files or directories, depending on the
configuration.")
(license license:expat)))
@@ -8709,7 +8709,7 @@ library.")
(list
#:import-path "github.com/joho/godotenv"))
(home-page "https://github.com/joho/godotenv")
- (synopsis "Golang libary to load environment variables from @code{.env}")
+ (synopsis "Golang library to load environment variables from @code{.env}")
(description
"This package provides a Go port of the Ruby's dotenv library
https://github.com/bkeepers/dotenv.")
@@ -12302,7 +12302,7 @@ included in this package.")
(home-page "https://github.com/otiai10/copy")
(synopsis "Go copy directory recursively")
(description
- "This package implments recursive copy functinoality for directory.")
+ "This package implements recursive copy functinoality for directory.")
(license license:expat)))
(define-public go-github-com-outcaste-io-ristretto
@@ -16209,7 +16209,7 @@ It's an alternative fork of @url{https://github.com/titanous/json5}.")
(home-page "https://github.com/zyedidia/poller")
(synopsis "File-descriptor multiplexer based on epoll(7)")
(description
- "Package poller is a file-descriptor multiplexer. It allows concurent
+ "Package poller is a file-descriptor multiplexer. It allows concurrent
Read and Write operations from and to multiple file-descriptors without
allocating one OS thread for every blocked operation. It operates similarly
to Go's netpoller (which multiplexes network connections) without requiring