summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ecdc081424..0815535bbe 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22536,7 +22536,7 @@ featuring zero allocations, composability, and iterator-like interfaces.")
(define-public rust-futures-core-0.3
(package
(name "rust-futures-core")
- (version "0.3.12")
+ (version "0.3.26")
(source
(origin
(method url-fetch)
@@ -22545,9 +22545,12 @@ featuring zero allocations, composability, and iterator-like interfaces.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0r8ag0mkxx9cd74yrccjk31lph4gr6lhgb9di6rx39wdvrfi9rbr"))))
+ "02467z5mv0219hkrgmpvsb3h7vb8pg31s1j901h7vxg11x6zz47c"))))
(build-system cargo-build-system)
- (arguments '(#:skip-build? #t))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-portable-atomic" ,rust-portable-atomic-1))))
(home-page "https://rust-lang.github.io/futures-rs")
(synopsis "Core traits and types in for the @code{futures} library")
(description "This package provides the core traits and types in for the