summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 324bf47aa7..912444bc8e 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2021 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2022 ( <[email protected]>
;;; Copyright © 2022 Efraim Flashner <[email protected]>
+;;; Copyright © 2023 Benjamin <[email protected]>
;;; Copyright © 2023 Felix Lechner <[email protected]>
;;; Copyright © 2023 Hilton Chain <[email protected]>
;;; Copyright © 2023 Katherine Cox-Buday <[email protected]>
@@ -351,6 +352,30 @@ builds on top of Go's builtin @code{testing} library and is complemented by the
Gomega matcher library.")
(license license:expat)))
+(define-public go-github-com-prashantv-gostub
+ (package
+ (name "go-github-com-prashantv-gostub")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prashantv/gostub")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "035xf5w4fqlicdbbjcflsqflc0z5gmrn6wr7q41xwqfwfpraf9ah"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/prashantv/gostub"))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/prashantv/gostub")
+ (synopsis "Stubbing library for Go")
+ (description
+ "Package gostub is used for stubbing variables in tests, and resetting the
+original value once the test has been run.")
+ (license license:expat)))
+
(define-public go-github-com-stretchr-testify
(package
(name "go-github-com-stretchr-testify")