summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-crypto.scm25
-rw-r--r--gnu/packages/golang.scm26
2 files changed, 25 insertions, 26 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 303024f9e4..7e3588f209 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1908,6 +1908,31 @@ adding the ability to obtain the list of host key algorithms for a known
host.")
(license license:asl2.0)))
+(define-public go-github-com-spaolacci-murmur3
+ (package
+ (name "go-github-com-spaolacci-murmur3")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spaolacci/murmur3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lv3zyz3jy2d76bhvvs8svygx66606iygdvwy5cwc0p5z8yghq25"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/spaolacci/murmur3"))
+ (home-page "https://github.com/spaolacci/murmur3")
+ (synopsis "Native MurmurHash3 Go implementation")
+ (description
+ "Native Go implementation of Austin Appleby's third MurmurHash
+revision (aka MurmurHash3). Reference algorithm has been slightly hacked as
+to support the streaming mode required by Go's standard Hash interface.")
+ (license license:bsd-3)))
+
(define-public go-github-com-twmb-murmur3
(package
(name "go-github-com-twmb-murmur3")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 91bb63417e..1ed230a19c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2622,32 +2622,6 @@ and lookup requests. Browse requests are not supported yet.")
(description "Go wrapper for taglib")
(license license:unlicense))))
-(define-public go-github-com-spaolacci-murmur3
- (package
- (name "go-github-com-spaolacci-murmur3")
- (version "1.1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/spaolacci/murmur3")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1lv3zyz3jy2d76bhvvs8svygx66606iygdvwy5cwc0p5z8yghq25"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/spaolacci/murmur3"))
- (home-page "https://github.com/spaolacci/murmur3")
- (synopsis "Native MurmurHash3 Go implementation")
- (description "Native Go implementation of Austin Appleby's third MurmurHash
-revision (aka MurmurHash3).
-
-Reference algorithm has been slightly hacked as to support the streaming mode
-required by Go's standard Hash interface.")
- (license license:bsd-3)))
-
(define-public go-github-com-sabhiram-go-gitignore
(let ((commit "525f6e181f062064d83887ed2530e3b1ba0bc95a")
(revision "1"))