summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <[email protected]>2020-06-22 02:56:22 +0200
committerJakub Kądziołka <[email protected]>2020-06-22 02:56:22 +0200
commit43bc7855113bd725d464dd9eaa1e54e78edfaab1 (patch)
tree2655f85e9946ececdb4fb052c2f3e31375c41e0f /gnu/packages/tor.scm
parent0c4e39c0b025fb23a2e5df46434fc96112bb6d6c (diff)
parentf8a28b6c6d4fe7642b7df35e8518e3c0174ede74 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm25
1 files changed, 23 insertions, 2 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 2f2623b0e6..19ab5cf374 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Rutger Helling <[email protected]>
;;; Copyright © 2018 Ricardo Wurmus <[email protected]>
;;; Copyright © 2020 Vincent Legoll <[email protected]>
+;;; Copyright © 2020 Brice Waegeneire <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -141,8 +142,28 @@ rejects UDP traffic from the application you're using.")
;; $out/etc/privoxy.
#:configure-flags (list (string-append "--sysconfdir="
(assoc-ref %outputs "out")
- "/etc/privoxy"))
- #:tests? #f))
+ "/etc/privoxy")
+ "--localstatedir=/var")
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-default-logging
+ (lambda _
+ (with-fluids ((%default-port-encoding "ISO-8859-1"))
+ ;; Do not create /var/run nor /var/log/privoxy/logfile.
+ (substitute* "GNUmakefile.in"
+ (("(logfile \\|\\| exit )1" _ match)
+ (string-append match "0"))
+ (("(\\$\\(DESTDIR\\)\\$\\(SHARE_DEST\\)) \\\\" _ match)
+ match)
+ ((".*\\$\\(LOG_DEST\\) \\$\\(DESTDIR\\)\\$\\(PID_DEST\\).*")
+ ""))
+ ;; Disable logging in the default configuration to allow for
+ ;; non-root users using it as is.
+ (substitute* "config"
+ (("^logdir") "#logdir")
+ (("^logfile") "#logfile")))
+ #t)))))
(inputs
`(("w3m" ,w3m)
("pcre" ,pcre)