summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2022-02-13 14:24:53 +0100
committerMarius Bakke <[email protected]>2022-02-13 14:24:53 +0100
commit76b6bbdf232b4b82cdd23cfe0d81331a4fd2edec (patch)
tree0e6a57ba08b9c6f9f5cbcdc5b5d9daeea91e428d /gnu/packages/simulation.scm
parent1a5302435ff0d2822b823f5a6fe01faa7a85c629 (diff)
parente8af2ea63a7f497b8f8e19e206645109c0646e72 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 240549be47..3f2d8e136d 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2018, 2019, 2020, 2021 Paul Garlick <[email protected]>
;;; Copyright © 2021 Maxim Cournoyer <[email protected]>
+;;; Copyright © 2022 Eric Bavier <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -430,6 +431,10 @@ FFC is part of the FEniCS Project.")
(sha256
(base32
"1m91hwcq5gfj4qqswp8l8kj58nia48f0n4kq13w0xqj4biq7rla0"))
+ (patches (search-patches "fenics-dolfin-algorithm.patch"
+ "fenics-dolfin-demo-init.patch"
+ "fenics-dolfin-boost.patch"
+ "fenics-dolfin-config-slepc.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -498,11 +503,8 @@ FFC is part of the FEniCS Project.")
;; git-lfs, so only the links are downloaded. The tests that
;; require the absent meshes cannot run and are skipped.
;;
- ;; Two other serial tests fail and are skipped.
- ;; i) demo_stokes-iterative_serial,
- ;; The MPI_Comm_rank() function was called before MPI_INIT was
- ;; invoked
- ;; ii) demo_multimesh-stokes_serial:
+ ;; One serial test fails and is skipped.
+ ;; i) demo_multimesh-stokes_serial:
;; Warning: Found no facets matching domain for boundary
;; condition.
;;
@@ -544,8 +546,6 @@ FFC is part of the FEniCS Project.")
"demo_mesh-quality_serial "
"demo_mesh-quality_mpi "
"demo_multimesh-stokes_serial "
- "demo_stokes-iterative_serial "
- "demo_stokes-iterative_mpi "
")\n") port)))
#t))
(replace 'check