summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2023-04-15 23:34:01 -0400
committerMaxim Cournoyer <[email protected]>2023-04-19 20:12:13 -0400
commit9df900341fa60f7a945bffd2ec00a59ece4d6f7b (patch)
treecec05367bf0528113ca81b1ab39888a0cd687233 /gnu/packages/python-xyz.scm
parent3928e3d426093f266b07c958d1f8c134c8d097f6 (diff)
gnu: python-typing-extensions: Move to (gnu packages python-build).
* gnu/packages/python-xyz.scm (python-typing-extensions): Move to... * gnu/packages/python-build.scm (python-typing-extensions): ... here.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ad90e2f3e5..a595ec3a21 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22645,44 +22645,6 @@ based on the CPython 2.7 and 3.7 parsers.")
with PEP 484 argument (and return) type annotations.")
(license license:expat)))
-(define-public python-typing-extensions
- (package
- (name "python-typing-extensions")
- (version "4.3.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "typing_extensions" version))
- (sha256
- (base32
- "19n4l57qazwrbvxjrbxw2vvfyd0zbk8ivnwm4zmwfzzl69x6glp6"))))
- (build-system pyproject-build-system)
- ;; The test suite requires Python's test module, not available in Guix.
- (arguments (list #:tests? #f))
- (native-inputs (list python-flit-core))
- (home-page "https://github.com/python/typing/typing_extensions")
- (synopsis "Experimental type hints for Python")
- (description
- "The typing_extensions module contains additional @code{typing} hints not
-yet present in the of the @code{typing} standard library.
-Included are implementations of:
-@enumerate
-@item ClassVar
-@item ContextManager
-@item Counter
-@item DefaultDict
-@item Deque
-@item NewType
-@item NoReturn
-@item overload
-@item Protocol
-@item runtime
-@item Text
-@item Type
-@item TYPE_CHECKING
-@item AsyncGenerator
-@end enumerate\n")
- (license license:psfl)))
-
(define-public bpython
(package
(name "bpython")