summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-27 20:17:20 +0000
committerSharlatan Hellseher <[email protected]>2025-01-27 21:22:32 +0000
commita35e975e162d43fff34a643a98b1aa4f5b5bc639 (patch)
treeaeb159d889fdcf911622e5f7e79369e2b527ecc7 /gnu/packages/python-science.scm
parentb17657ee86e31c81e923bd3d91dad1a377a6917a (diff)
gnu: python-deepdish: Fix indentation.
* gnu/packages/python-science.scm (python-deepdish): Fix indentation. Change-Id: Idf8a0b5cdb9e371cb5d1f5f51f993da6209342d5
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm93
1 files changed, 47 insertions, 46 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index f80ae19b23..49738d8559 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -3524,60 +3524,61 @@ data.")
;; packed in Guix (now 1.24.4), use the latest commit containing fixes.
;; See: <https://github.com/uchicago-cs/deepdish/issues/50>.
;; However, there is a maintained fork that appears to be a good
- ;; replacement: https://github.com/portugueslab/flammkuchen.
+ ;; replacement: https://github.com/portugueslab/flammkuchen.
(let ((commit "3f2dff7a03f1b31f6924b665ad5b8c299329c1cd")
(revision "0"))
- (package
- (name "python-deepdish")
- (version (git-version "0.3.7" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/uchicago-cs/deepdish")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1n3r6z5zd18kdmzyg1gkm9lqi573szlxbls1ck5wjn4a14ar9fw3"))))
- (arguments
- ;; Disable few failing tests to pass the build.
- (list #:test-flags
- #~(list "-k" (string-append "not test_pad"
- " and not test_pad_repeat_border"
- " and not test_pad_repeat_border_corner"
- " and not test_pad_to_size"))
- #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'dont-vendor-six
- (lambda _
- (delete-file "deepdish/six.py")
- (substitute* "deepdish/io/hdf5io.py"
- (("from deepdish import six") "import six"))
- (substitute* "deepdish/io/ls.py"
- (("from deepdish import io, six, __version__")
- "from deepdish import io, __version__
+ (package
+ (name "python-deepdish")
+ (version (git-version "0.3.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/uchicago-cs/deepdish")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n3r6z5zd18kdmzyg1gkm9lqi573szlxbls1ck5wjn4a14ar9fw3"))))
+ (arguments
+ ;; Disable few failing tests to pass the build.
+ (list
+ #:test-flags
+ #~(list "-k" (string-append "not test_pad"
+ " and not test_pad_repeat_border"
+ " and not test_pad_repeat_border_corner"
+ " and not test_pad_to_size"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'dont-vendor-six
+ (lambda _
+ (delete-file "deepdish/six.py")
+ (substitute* "deepdish/io/hdf5io.py"
+ (("from deepdish import six") "import six"))
+ (substitute* "deepdish/io/ls.py"
+ (("from deepdish import io, six, __version__")
+ "from deepdish import io, __version__
import six
")))))))
- (build-system pyproject-build-system)
- (native-inputs
- (list python-pytest
- python-pandas
- python-setuptools
- python-wheel))
- (propagated-inputs
- (list python-numpy
- python-scipy
- python-six
- python-tables))
- (home-page "https://github.com/uchicago-cs/deepdish")
- (synopsis "Python library for HDF5 file saving and loading")
- (description
- "Deepdish is a Python library to load and save HDF5 files.
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-pandas
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-numpy
+ python-scipy
+ python-six
+ python-tables))
+ (home-page "https://github.com/uchicago-cs/deepdish")
+ (synopsis "Python library for HDF5 file saving and loading")
+ (description
+ "Deepdish is a Python library to load and save HDF5 files.
The primary feature of deepdish is its ability to save and load all kinds of
data as HDF5. It can save any Python data structure, offering the same ease
of use as pickling or @code{numpy.save}, but with the language
interoperability offered by HDF5.")
- (license license:bsd-3))))
+ (license license:bsd-3))))
(define-public python-simple-pid
(package