summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2023-01-07 14:11:55 +0100
committerMarius Bakke <[email protected]>2023-01-07 21:04:26 +0100
commitedbacab9953144a3aa204f9f0eee1584ef321a8f (patch)
tree375b90e501ed9094821796355bf57286052e02a9 /gnu/packages/python-check.scm
parenta47c475678c3647be918ebc97cced1e8a2306993 (diff)
gnu: Use old setuptools in packages that relies on use_2to3 conversion.
This fixes a regression since 520cdf80581669646ff61e9f18f3b27045556e76 where the use_2to3 functionality was removed from setuptools. * gnu/packages/graph.scm (python-louvain)[native-inputs]: Change from PYTHON-SETUPTOOLS to PYTHON-SETUPTOOLS-57. * gnu/packages/python-check.scm (python-parameterizedtestcase)[native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-anyjson)[native-inputs]: Add PYTHON-SETUPTOOLS-57. * gnu/packages/bioinformatics.scm (python-pyvcf)[native-inputs]: Change from PYTHON-SETUPTOOLS-FOR-TENSORFLOW to PYTHON-SETUPTOOLS-57.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 486abf1c13..7cb467c166 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2268,7 +2268,7 @@ Avocado machine readable outputs this one is streamlined (per test results).
(sha256
(base32 "0zhjmsd16xacg4vd7zb75kw8q9khn52wvad634v1bvz7swaivk2c"))))
(build-system python-build-system)
- (native-inputs (list python-setuptools)) ;for use_2to3
+ (native-inputs (list python-setuptools-57)) ;for use_2to3
(home-page
"https://github.com/msabramo/python_unittest_parameterized_test_case")
(synopsis "Parameterized tests for Python's unittest module")