summaryrefslogtreecommitdiff
path: root/gnu/packages/polkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2022-02-13 14:24:53 +0100
committerMarius Bakke <[email protected]>2022-02-13 14:24:53 +0100
commit76b6bbdf232b4b82cdd23cfe0d81331a4fd2edec (patch)
tree0e6a57ba08b9c6f9f5cbcdc5b5d9daeea91e428d /gnu/packages/polkit.scm
parent1a5302435ff0d2822b823f5a6fe01faa7a85c629 (diff)
parente8af2ea63a7f497b8f8e19e206645109c0646e72 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/polkit.scm')
-rw-r--r--gnu/packages/polkit.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index e4f4b1276f..1ae94be751 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Andreas Enge <[email protected]>
;;; Copyright © 2015 Andy Wingo <[email protected]>
-;;; Copyright © 2015, 2021 Ludovic Courtès <[email protected]>
+;;; Copyright © 2015, 2021-2022 Ludovic Courtès <[email protected]>
;;; Copyright © 2015 Mark H Weaver <[email protected]>
;;; Copyright © 2016 Efraim Flashner <[email protected]>
;;; Copyright © 2017 Huang Ying <[email protected]>
@@ -54,6 +54,7 @@
(package
(name "polkit")
(version "0.120")
+ (replacement polkit-mozjs/fixed)
(source (origin
(method url-fetch)
(uri (string-append
@@ -146,6 +147,16 @@ making process with respect to granting access to privileged operations
for unprivileged applications.")
(license lgpl2.0+)))
+(define-public polkit-mozjs/fixed
+ (package
+ (inherit polkit-mozjs)
+ (version "0.121")
+ (source (origin
+ (inherit (package-source polkit-mozjs))
+ (patches (cons (search-patch "polkit-CVE-2021-4034.patch")
+ (origin-patches
+ (package-source polkit-mozjs))))))))
+
;;; Variant of polkit built with Duktape, a lighter JavaScript engine compared
;;; to mozjs.
(define-public polkit-duktape