summaryrefslogtreecommitdiff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2022-09-15 10:20:32 -0400
committerMaxim Cournoyer <[email protected]>2022-09-15 10:20:32 -0400
commit3d297a0017210f1dd135592efb10846840a8af88 (patch)
tree8868c35a558a6288b5097d65bee42dda291178e4 /gnu/packages/patchutils.scm
parent279349209e44aaae6ca2aba328fe2a4d2da99f12 (diff)
parent6737d8d3248301e65bc24291b1a776e4aa8c3648 (diff)
Merge branch 'master' into staging
With resolved conflicts in: gnu/local.mk gnu/packages/freedesktop.scm gnu/packages/gnuzilla.scm
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index fdbcb8e1e1..dd5e6bae9a 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019 Christopher Baines <[email protected]>
;;; Copyright © 2021 Xinglu Chen <[email protected]>
+;;; Copyright © 2022 jgart <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages patchutils)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix licenses)
@@ -40,6 +42,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages gtk)
#:use-module (gnu packages less)
#:use-module (gnu packages mail)
@@ -441,6 +444,41 @@ Users can login allowing them to change the state of patches.")
(home-page "http://jk.ozlabs.org/projects/patchwork/")
(license gpl2+)))
+(define-public wiggle
+ (package
+ (name "wiggle")
+ (version "1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/neilbrown/wiggle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18ilzr9sbal1j8p1d94ilm1j5blac5cngvcvjpdmgmpw6diy2ldf"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags
+ #~(list "CFLAGS=-I. -O3" "INSTALL=install" "STRIP=-s"
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "BINDIR=" #$output "/bin")
+ (string-append "MANDIR=" #$output "/share/man")
+ (string-append "PREFIX=" #$output))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://neil.brown.name/wiggle/")
+ (inputs (list ncurses))
+ (native-inputs (list groff))
+ (synopsis "Apply patches with conflicts")
+ (description
+ "@code{wiggle} attempts to apply patches to a target file even if the
+patches do not match perfectly.")
+ (license gpl2+)))
+
(define-public pwclient
(package
(name "pwclient")