summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/torcs-nullptr.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2024-10-23 20:48:20 +0900
committerMaxim Cournoyer <[email protected]>2024-11-12 17:41:38 +0900
commit40625c213ad2007f70117518a7cc290d367e652a (patch)
tree900492fcfb67ecf76d7151d75c40987143cf3831 /gnu/packages/patches/torcs-nullptr.patch
parentf0c27b2fa824a43bc6a6d056ec7a7c5c78c3a367 (diff)
gnu: Add torcs.
* gnu/packages/games.scm (torcs): New variable. Change-Id: I1e55fc65ff303c309fed50f2071de0eaf4266d57
Diffstat (limited to 'gnu/packages/patches/torcs-nullptr.patch')
-rw-r--r--gnu/packages/patches/torcs-nullptr.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/torcs-nullptr.patch b/gnu/packages/patches/torcs-nullptr.patch
new file mode 100644
index 0000000000..a002c48169
--- /dev/null
+++ b/gnu/packages/patches/torcs-nullptr.patch
@@ -0,0 +1,14 @@
+Source: https://src.fedoraproject.org/rpms/torcs/raw/rawhide/f/torcs-1.3.7-nullptr.patch
+Upstream-status: https://sourceforge.net/p/torcs/mailman/message/36490328/
+
+--- torcs-1.3.7/src/libs/musicplayer/OpenALMusicPlayer.cpp.orig 2014-02-05 10:54:43.000000000 +0100
++++ torcs-1.3.7/src/libs/musicplayer/OpenALMusicPlayer.cpp 2018-07-09 20:56:42.521607205 +0100
+@@ -161,7 +161,7 @@
+ {
+ char pcm[BUFFERSIZE];
+ int size = 0;
+- const char* error = '\0';
++ const char* error = nullptr;
+
+ if (!stream->read(pcm, BUFFERSIZE, &size, &error)) {
+ GfError("OpenALMusicPlayer: Stream read error: %s\n", error);