summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rust-1.78-unwinding-fix.patch
diff options
context:
space:
mode:
authorBrennan Vincent <[email protected]>2024-08-26 13:40:54 -0400
committerEfraim Flashner <[email protected]>2024-11-28 11:04:08 +0200
commitd3f5963b7ce4b06d4aa0f3fa4119fd6c3f5f46e3 (patch)
treeba65b09f747d5e0c26dcb9aca5f47a9db648d841 /gnu/packages/patches/rust-1.78-unwinding-fix.patch
parent8a28ba76126cbbd2a6d61e864f576e7a7bd7a763 (diff)
gnu: rust: Update to 1.78.
* gnu/packages/rust.scm (rust): Update to 1.78. [source]: Adjust removal of bundled source libraries. [arguments]: Add a phase skipping tests requiring crates.io. (rust-1.78)[source]: Add patch. * gnu/packages/patches/rust-1.78-unwinding-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I7bf37a9321447ac21644af0e2d023b8bc556da59 Signed-off-by: Efraim Flashner <[email protected]>
Diffstat (limited to 'gnu/packages/patches/rust-1.78-unwinding-fix.patch')
-rw-r--r--gnu/packages/patches/rust-1.78-unwinding-fix.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/rust-1.78-unwinding-fix.patch b/gnu/packages/patches/rust-1.78-unwinding-fix.patch
new file mode 100644
index 0000000000..8e98d6d7d9
--- /dev/null
+++ b/gnu/packages/patches/rust-1.78-unwinding-fix.patch
@@ -0,0 +1,29 @@
+From ce49a9d9e52ca6062fe0894e72d954511fa8820f Mon Sep 17 00:00:00 2001
+From: Shmuel Hazan <[email protected]>
+Date: Sat, 1 Jun 2024 08:49:44 +0300
+Subject: [PATCH] Add UWTable attr to functions with a personality function
+
+Adding a personality function forces LLVM to generate unwinding info that might be incorrect.
+To solve it, always apply the UWTable attribute when setting a personality function.
+
+Fixes #123733
+---
+ compiler/rustc_codegen_llvm/src/builder.rs | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/compiler/rustc_codegen_llvm/src/builder.rs b/compiler/rustc_codegen_llvm/src/builder.rs
+index 72ff9ea118e28..668f0a33a4e80 100644
+--- a/compiler/rustc_codegen_llvm/src/builder.rs
++++ b/compiler/rustc_codegen_llvm/src/builder.rs
+@@ -1029,6 +1029,11 @@ impl<'a, 'll, 'tcx> BuilderMethods<'a, 'tcx> for Builder<'a, 'll, 'tcx> {
+ }
+
+ fn set_personality_fn(&mut self, personality: &'ll Value) {
++ // Work around for https://github.com/rust-lang/rust/issues/123733
++ // add the UWTable attribute to every function with a personality function.
++ let uwtable = attributes::uwtable_attr(self.llcx, None);
++ attributes::apply_to_llfn(self.llfn(), llvm::AttributePlace::Function, &[uwtable]);
++
+ unsafe {
+ llvm::LLVMSetPersonalityFn(self.llfn(), personality);
+ }