summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch
diff options
context:
space:
mode:
authorNicolas Graves <[email protected]>2024-05-10 00:53:04 +0200
committerSharlatan Hellseher <[email protected]>2024-12-13 20:18:48 +0000
commitb4c39bb2db388c50e36d39ec1cd7eb063b144cd7 (patch)
tree18fc85f09be01daa38a062b1f7feb24094fd6fcd /gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch
parent7779c5e794cef27d331bcab1e9334e00b1606efa (diff)
gnu: python-aionotify: Update to 0.3.0.
* gnu/packages/python-xyz.scm (python-aionotify): Update to 0.3.0. [build-system]: Move to pyproject-build-system. * gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch : Remove patch. * gnu/local.mk: Remove patch. Change-Id: I9f13d6d71f69dd9877ac42e46b087989f23941e2 Signed-off-by: Nicolas Goaziou <[email protected]>
Diffstat (limited to 'gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch')
-rw-r--r--gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch b/gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch
deleted file mode 100644
index ebeef34720..0000000000
--- a/gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Compatibility with Python 3.8, see upstream issue
-https://github.com/rbarrois/aionotify/pull/15
-
-diff --git a/setup.py b/setup.py
-index 21a554f..094de64 100755
---- a/setup.py
-+++ b/setup.py
-@@ -40,7 +40,7 @@ setup(
- setup_requires=[
- ],
- tests_require=[
-- 'asynctest',
-+ 'asynctest; python_version<"3.8"',
- ],
- classifiers=[
- "Development Status :: 4 - Beta",
-diff --git a/tests/test_usage.py b/tests/test_usage.py
-index f156291..0476ff1 100644
---- a/tests/test_usage.py
-+++ b/tests/test_usage.py
-@@ -8,7 +8,11 @@ import os.path
- import tempfile
- import unittest
-
--import asynctest
-+try:
-+ testBase = unittest.IsolatedAsyncioTestCase
-+except AttributeError:
-+ import asynctest
-+ testBase = asynctest.TestCase
-
- import aionotify
-
-@@ -25,11 +29,13 @@ if AIODEBUG:
- TESTDIR = os.environ.get('AIOTESTDIR') or os.path.join(os.path.dirname(__file__), 'testevents')
-
-
--class AIONotifyTestCase(asynctest.TestCase):
-+class AIONotifyTestCase(testBase):
- forbid_get_event_loop = True
- timeout = 3
-
- def setUp(self):
-+ if not getattr (self, 'loop', None):
-+ self.loop = asyncio.get_event_loop()
- if AIODEBUG:
- self.loop.set_debug(True)
- self.watcher = aionotify.Watcher()