summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/guile-fibers-cross-build-fix.patch
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <[email protected]>2024-11-02 13:36:41 +0100
committerJan (janneke) Nieuwenhuizen <[email protected]>2024-11-02 14:04:19 +0100
commit20c7b8dd04e421a139a02438cf1ddfdfe544a446 (patch)
tree178ee403f9c0c32591b1e8e3e2fca827e0ea95fb /gnu/packages/patches/guile-fibers-cross-build-fix.patch
parentea11d3608566174c4bae70faa4f9d0c67748d2db (diff)
gnu: guile-fibers: Fix cross-build to the Hurd.
This fixes <https://lists.gnu.org/archive/html/guile-user/2024-10/msg00009.html>, <https://github.com/wingo/fibers/issues/111>. * gnu/packages/patches/guile-fibers-cross-build-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/guile-xyz.scm (guile-fibers)[arguments]: When cross-building, add `apply-cross-build-fix-patch' phase to apply it. Change-Id: Ic845db832b9446c8cb5b534cc2db63b98c417b1a
Diffstat (limited to 'gnu/packages/patches/guile-fibers-cross-build-fix.patch')
-rw-r--r--gnu/packages/patches/guile-fibers-cross-build-fix.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-fibers-cross-build-fix.patch b/gnu/packages/patches/guile-fibers-cross-build-fix.patch
new file mode 100644
index 0000000000..b4037d705e
--- /dev/null
+++ b/gnu/packages/patches/guile-fibers-cross-build-fix.patch
@@ -0,0 +1,40 @@
+Upstream-status: Presented to [email protected].
+
+From cfdf36ee5dc2a854781cd2ba27a8ced776c7b313 Mon Sep 17 00:00:00 2001
+From: Janneke Nieuwenhuizen <[email protected]>
+Date: Sat, 2 Nov 2024 13:31:28 +0100
+Subject: [PATCH] build: Fix cross-building from i686-linux to i586-pc-gnu.
+Content-Transfer-Encoding: 8bit
+Content-Type: text/plain; charset=UTF-8
+
+Fixes #111.
+
+* build-aux/guile.am (.scm.go)[CROSS_COMPILING]: Do not go through
+./env.
+---
+ build-aux/guile.am | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/build-aux/guile.am b/build-aux/guile.am
+index 5e94c96..db8ab72 100644
+--- a/build-aux/guile.am
++++ b/build-aux/guile.am
+@@ -22,7 +22,14 @@ CLEANFILES = $(GOBJECTS)
+ EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+ GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
+ SUFFIXES = .scm .go
++if CROSS_COMPILING
++.scm.go:
++ $(AM_V_GEN) \
++ $(GUILE_TOOLS) compile $(GUILE_TARGET) -L "$(abs_top_srcdir)" \
++ $(GUILE_WARNINGS) -o "$@" "$<"
++else
+ .scm.go:
+ $(AM_V_GEN) $(top_builddir)/env \
+ $(GUILE_TOOLS) compile $(GUILE_TARGET) -L "$(abs_top_srcdir)" \
+ $(GUILE_WARNINGS) -o "$@" "$<"
++endif
+--
+Janneke Nieuwenhuizen <[email protected]> | GNU LilyPond https://LilyPond.org
+Freelance IT https://www.JoyOfSource.com | AvatarĀ® https://AvatarAcademy.com
+