summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/guile-3.0-crash.patch
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2020-03-10 20:45:24 +0100
committerMarius Bakke <[email protected]>2020-03-10 20:45:24 +0100
commit2d421c4f19a0669879c9a8738361a151b1431d4f (patch)
treed814cdb0fa1bdf763973ea43d89e22eab1da42e0 /gnu/packages/patches/guile-3.0-crash.patch
parentb3b5714fa72bf661003f27fbccba5697f5810115 (diff)
parent90799c35bd9cadaf7c28be5ea6e41ec692d5b4a4 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/guile-3.0-crash.patch')
-rw-r--r--gnu/packages/patches/guile-3.0-crash.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-3.0-crash.patch b/gnu/packages/patches/guile-3.0-crash.patch
new file mode 100644
index 0000000000..510834ab57
--- /dev/null
+++ b/gnu/packages/patches/guile-3.0-crash.patch
@@ -0,0 +1,17 @@
+Fix crash due to: <https://issues.guix.gnu.org/issue/39266>.
+
+diff --git a/libguile/struct.c b/libguile/struct.c
+index 3dbcc71d4..ddcbe46d2 100644
+--- a/libguile/struct.c
++++ b/libguile/struct.c
+@@ -139,7 +139,9 @@ set_vtable_access_fields (SCM vtable)
+ nfields = len / 2;
+
+ bitmask_size = (nfields + 31U) / 32U;
+- unboxed_fields = scm_gc_malloc_pointerless (bitmask_size, "unboxed fields");
++ unboxed_fields =
++ scm_gc_malloc_pointerless (bitmask_size * sizeof (*unboxed_fields),
++ "unboxed fields");
+ memset (unboxed_fields, 0, bitmask_size * sizeof(*unboxed_fields));
+
+ /* Update FLAGS according to LAYOUT. */