summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2022-02-13 14:24:53 +0100
committerMarius Bakke <[email protected]>2022-02-13 14:24:53 +0100
commit76b6bbdf232b4b82cdd23cfe0d81331a4fd2edec (patch)
tree0e6a57ba08b9c6f9f5cbcdc5b5d9daeea91e428d /gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
parent1a5302435ff0d2822b823f5a6fe01faa7a85c629 (diff)
parente8af2ea63a7f497b8f8e19e206645109c0646e72 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/bloomberg-bde-cmake-module-path.patch')
-rw-r--r--gnu/packages/patches/bloomberg-bde-cmake-module-path.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch b/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
new file mode 100644
index 0000000000..b08ca5eac0
--- /dev/null
+++ b/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
@@ -0,0 +1,16 @@
+This package requires CMAKE_MODULE_PATH be set by the calling process. This
+patch uses the CMAKE_PREFIX_PATH passed from Guix as the search path for
+locating the bloomberg-bde-tools CMake modules.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,8 +1,6 @@
+ cmake_minimum_required(VERSION 3.15)
+
+-if (NOT CMAKE_MODULE_PATH)
+- message(FATAL "Please specify path to BDE cmake modules.")
+-endif()
++string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
+
+ get_filename_component(repoName ${CMAKE_CURRENT_LIST_DIR} NAME)
+