summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2023-03-28 22:40:32 -0400
committerMaxim Cournoyer <[email protected]>2023-03-28 22:40:32 -0400
commit438a0de332fc09d9ba14d7c989af9c17ca9c6be2 (patch)
tree869ee142cd19a803ce4d1e33d69d0d85f3be5a44 /gnu/packages/maths.scm
parente5ae499f4c91508123edae3df29afa94c6ef33ae (diff)
parentd00f1075077e55a3c2c750b3dd41be2a09eff530 (diff)
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm79
1 files changed, 39 insertions, 40 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1853c77a14..95bd5a6578 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1235,14 +1235,14 @@ in the terminal or with an external viewer.")
(define-public gnuplot
(package
(name "gnuplot")
- (version "5.4.4")
+ (version "5.4.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnuplot/gnuplot/"
version "/gnuplot-"
version ".tar.gz"))
(sha256
- (base32 "00h97y8njhvfjbdvc0njw0znxbrlfynd1iazn8w3anvzhsvh08rp"))))
+ (base32 "06bly8cpqjdf744jg7yrgba9rdcm3gl4zf63y3c69v80ha8jgz02"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config texlive-tiny))
@@ -3041,47 +3041,47 @@ can solve two kinds of problems:
(define-public octave-cli
(package
(name "octave-cli")
- (version "7.3.0")
+ (version "8.1.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/octave/octave-"
- version ".tar.xz"))
- (sha256
- (base32
- "1wap9p9imxxqpnm27rxcvpjahk1wg440lzlygjb6iyncxdmfw255"))))
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/octave/octave-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "00lis18dsb13v9nvz0z4cs7v4y634jc0vb04lxfw9pshwriikglv"))))
(build-system gnu-build-system)
(inputs
- `(("alsa-lib" ,alsa-lib)
- ("arpack" ,arpack-ng)
- ("bdb" ,bdb)
- ("curl" ,curl)
- ("fftw" ,fftw)
- ("fftwf" ,fftwf)
- ("fltk" ,fltk)
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("gl2ps" ,gl2ps)
- ("glpk" ,glpk)
- ("glu" ,glu)
- ("graphicsmagick" ,graphicsmagick)
-
- ;; TODO: libjpeg-turbo is indirectly required through libtiff. In
- ;; the next rebuild cycle, add an absolute reference for -ljpeg in
- ;; libtiff.la instead of having to provide it here.
- ("libjpeg" ,libjpeg-turbo)
+ (list alsa-lib
+ arpack-ng
+ bdb
+ curl
+ fftw
+ fftwf
+ fltk
+ fontconfig
+ freetype
+ gl2ps
+ glpk
+ glu
+ graphicsmagick
- ("hdf5" ,hdf5)
- ("lapack" ,lapack)
- ("libsndfile" ,libsndfile)
- ("libxft" ,libxft)
- ("mesa" ,mesa)
- ("pcre" ,pcre)
- ("portaudio" ,portaudio)
- ("qhull" ,qhull)
- ("readline" ,readline)
- ("suitesparse" ,suitesparse)
- ("zlib" ,zlib)))
+ ;; TODO: libjpeg-turbo is indirectly required through libtiff. In
+ ;; the next rebuild cycle, add an absolute reference for -ljpeg in
+ ;; libtiff.la instead of having to provide it here.
+ libjpeg-turbo
+
+ hdf5
+ lapack
+ libsndfile
+ libxft
+ mesa
+ pcre
+ portaudio
+ qhull
+ readline
+ suitesparse
+ zlib))
(native-inputs
(list gfortran
pkg-config
@@ -3121,8 +3121,7 @@ can solve two kinds of problems:
(substitute* "libinterp/corefcn/help.h"
(("\"makeinfo\"")
(string-append
- "\"" (assoc-ref inputs "texinfo") "/bin/makeinfo\"")))
- #t)))))
+ "\"" (assoc-ref inputs "texinfo") "/bin/makeinfo\""))))))))
(home-page "https://www.gnu.org/software/octave/")
(synopsis "High-level language for numerical computation (no GUI)")
(description "GNU Octave is a high-level interpreted language that is