summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <[email protected]>2024-08-18 22:24:36 +0200
committerLudovic Courtès <[email protected]>2024-08-31 10:45:47 +0200
commita4f64b30b054b168a8affd5f246df338172a4da6 (patch)
treee300c3e651bd30cbc3fb0a34ad91675fb7c79605 /gnu/packages/haskell-xyz.scm
parent5d6c55d3641005d2939d140a5f533d7565f7404d (diff)
gnu: ghc-basement: Fix compilation on 32-bit platforms.
* gnu/packages/patches/ghc-basement-fix-32-bit.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/haskell-xyz.scm (ghc-basement)[arguments]: New field. Change-Id: I4d462754cad3daf8328e7d3c95c184a9e12a45cd
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 197a556f77..62b7268255 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -800,6 +800,18 @@ than @code{base-compat}, which has no dependencies.")
(sha256
(base32 "00332i4n98gh06x8ii4p8mhjpq0ch1bdan9hxmdblxpgk8j7xdvz"))))
(build-system haskell-build-system)
+ (arguments
+ (if (target-64bit?)
+ '()
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-for-32-bit-system
+ (lambda _
+ (define patch
+ #$(local-file
+ (search-patch "ghc-basement-fix-32-bit.patch")))
+
+ (invoke "patch" "-p1" "--force" "-i" patch)))))))
(properties '((upstream-name . "basement")))
(home-page "https://github.com/haskell-foundation/foundation#readme")
(synopsis "Basic primitives for Foundation starter pack")