summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <[email protected]>2020-06-22 02:56:22 +0200
committerJakub Kądziołka <[email protected]>2020-06-22 02:56:22 +0200
commit43bc7855113bd725d464dd9eaa1e54e78edfaab1 (patch)
tree2655f85e9946ececdb4fb052c2f3e31375c41e0f /gnu/packages/haskell-web.scm
parent0c4e39c0b025fb23a2e5df46434fc96112bb6d6c (diff)
parentf8a28b6c6d4fe7642b7df35e8518e3c0174ede74 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 4689025432..0c79ece194 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019 Robert Vollmert <[email protected]>
;;; Copyright © 2019 John Soo <[email protected]>
;;; Copyright © 2020 Alexandru-Sergiu Marton <[email protected]>
+;;; Copyright © 2020 Marius Bakke <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -93,6 +94,27 @@ for screen-scraping.")
(description "HTTP cookie parsing and rendering library for Haskell.")
(license license:bsd-3)))
+(define-public ghc-curl
+ (package
+ (name "ghc-curl")
+ (version "1.3.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://hackage/package/curl/curl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0vj4hpaa30jz7c702xpsfvqaqdxz28zslsqnsfx6bf6dpwvck1wh"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("curl" ,curl)))
+ (home-page "https://hackage.haskell.org/package/curl")
+ (synopsis "Haskell bindings for libcurl")
+ (description
+ "@code{libcurl} is a versatile client-side URL transfer library.
+This package provides a Haskell binding to libcurl.")
+ (license license:bsd-3)))
+
(define-public ghc-httpd-shed
(package
(name "ghc-httpd-shed")