summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2023-11-29 22:34:46 +0000
committerMaxim Cournoyer <[email protected]>2024-01-03 16:35:14 -0500
commit13ab4abe98f1a88256d4ecd9b3ee3cb026515f4e (patch)
tree511692cdb6223f70cb1ef2d2980cbd2846cc4623 /gnu/packages/golang-web.scm
parent7b2c29095672dd330b17ccabc01128a7e4f45924 (diff)
gnu: go-github-com-gorilla-websocket: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-gorilla-websocket): Move from here... * gnu/packages/golang-web.scm: ...to here. * gnu/packages/ipfs.scm: Add (gnu packages golang-web) module. Change-Id: I844738ec0b178a6a1746b01659c93a20919c2736
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 79a69bc842..0ca70cec38 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021, 2022 Efraim Flashner <[email protected]>
;;; Copyright © 2021 Sarah Morgensen <[email protected]>
;;; Copyright © 2022 Giacomo Leidi <[email protected]>
+;;; Copyright © 2022 muradm <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -161,6 +162,28 @@ the parse trees produced by the html package.")
incoming requests with their respective handler.")
(license license:bsd-3)))
+(define-public go-github-com-gorilla-websocket
+ (package
+ (name "go-github-com-gorilla-websocket")
+ (version "1.5.0")
+ (home-page "https://github.com/gorilla/websocket")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xrr6snvs9g1nzxxg05w4i4pq6k1xjljl5mvavd838qc468n118i"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gorilla/websocket"))
+ (synopsis "Fast WebSocket implementation for Go")
+ (description "Gorilla WebSocket is a Go implementation of the WebSocket
+protocol.")
+ (license license:bsd-2)))
+
(define-public go-github-com-puerkitobio-goquery
(package
(name "go-github-com-puerkitobio-goquery")