summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-10 21:39:56 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:51 +0000
commit79ede518d81fd6e99db0a87dd6a5a50a8e782262 (patch)
treee5091beeb376a448abf0e68f6823d50ae3064b6c /gnu/packages/golang-crypto.scm
parent981601b2c15e8fce43515af80f90a7fe515b4509 (diff)
gnu: Add go-software-sslmate-com-src-go-pkcs12.
* gnu/packages/golang-crypto.scm (go-software-sslmate-com-src-go-pkcs12): New variable. Change-Id: I54dabe976a94c2191c3805e1751ea612822b1783
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index b1940583d4..5f9a94247f 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1807,6 +1807,35 @@ contains AVX-512 and AVX2 routines (generated by avo) that greatly increase
performance for large inputs and outputs.")
(license license:expat)))
+(define-public go-software-sslmate-com-src-go-pkcs12
+ (package
+ (name "go-software-sslmate-com-src-go-pkcs12")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SSLMate/go-pkcs12")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bmkv9nxflgr5sbizpm737rbarmi8iyxny6pwdmqk0jzrg5ppd85"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "software.sslmate.com/src/go-pkcs12"))
+ (propagated-inputs
+ (list go-golang-org-x-crypto))
+ (home-page "https://github.com/SSLMate/go-pkcs12")
+ (synopsis "Encoding and decoding PKCS#12 files")
+ (description
+ "Package pkcs12 implements some of PKCS#12 (also known as P12 or PFX).
+It is intended for decoding DER-encoded P12/PFX files for use with the
+@code{crypto/tls} package, and for encoding P12/PFX files for use by legacy
+applications which do not support newer formats. Since PKCS#12 uses weak
+encryption primitives, it SHOULD NOT be used for new applications.")
+ (license license:bsd-3)))
+
(define-public go-torproject-org-pluggable-transports-goptlib
(package
(name "go-torproject-org-pluggable-transports-goptlib")