summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-22 01:15:39 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:14 +0000
commit6bc265ba9f6f4e612f01afcff2b341a149bb7b91 (patch)
tree345a0ea91d9f94fe7f78c5674694953dcd5c206c /gnu/packages/golang-crypto.scm
parent9b0a363f9b4f2ccecd2f7a647cb7a53e4f5aaf9a (diff)
gnu: Add go-github-com-pjbgf-sha1cd.
* gnu/packages/golang-crypto.scm (go-github-com-pjbgf-sha1cd): New variable. Change-Id: I62d5d315a505b19f7c87b3d40b1e980262fccf99
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 2a266e2fa3..dc4bbd0ba8 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1439,6 +1439,32 @@ algorithm.")
"This package provides primitives for generating random values.")
(license license:expat)))
+(define-public go-github-com-pjbgf-sha1cd
+ (package
+ (name "go-github-com-pjbgf-sha1cd")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pjbgf/sha1cd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1g07kp07kvbsmpdrrv0r805vw4rr1mp77vx06m31nxvnp1s42zwi"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pjbgf/sha1cd"))
+ (home-page "https://github.com/pjbgf/sha1cd")
+ (synopsis "sha1cd")
+ (description
+ "Package sha1cd implements collision detection based on the whitepaper
+Counter-cryptanalysis from Marc Stevens. The original ubc implementation was
+done by Marc Stevens and Dan Shumow, and can be found at:
+@@url{https://github.com/cr-marcstevens/sha1collisiondetection,https://github.com/cr-marcstevens/sha1collisiondetection}.")
+ (license license:asl2.0)))
+
(define-public go-github-com-protonmail-go-crypto
(package
(name "go-github-com-protonmail-go-crypto")