summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2019-08-08 00:35:37 +0200
committerMarius Bakke <[email protected]>2019-08-08 00:35:37 +0200
commit8e7f97b9ffee10af3cf16958ebc0a7d410a19ca8 (patch)
treeb3836f9cea849fd8bfb61a77ba225a0054babe58 /gnu/packages/geo.scm
parentfa228db78bc9dcb0e7da607dd8783224c76d7ef5 (diff)
parentba7ff983d613f735ee270f0b0e3c5dba5cbeda3c (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8005c46129..edb3b49841 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -131,7 +131,12 @@ topology functions.")
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
(goa-path (string-append
(assoc-ref inputs "gnome-online-accounts")
+ "/lib:"
+ (assoc-ref inputs "gnome-online-accounts:lib")
"/lib"))
+ (geocode-glib-path (string-append
+ (assoc-ref inputs "geocode-glib")
+ "/lib"))
(webkitgtk-path (string-append
(assoc-ref inputs "webkitgtk")
"/lib")))
@@ -141,7 +146,8 @@ topology functions.")
;; There seems to be no way to embed the path of
;; libgoa-1.0.so.0, libwebkit2gtk-4.0.so.37 and
;; libjavascriptcoregtk-4.0.so.18.
- `("LD_LIBRARY_PATH" ":" prefix (,goa-path ,webkitgtk-path)))
+ `("LD_LIBRARY_PATH" ":" prefix
+ (,goa-path ,webkitgtk-path ,geocode-glib-path)))
#t))))))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
@@ -163,6 +169,7 @@ topology functions.")
("gjs" ,gjs)
("glib" ,glib)
("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("rest" ,rest)
("webkitgtk" ,webkitgtk)))