summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2020-06-14 16:24:34 +0200
committerMarius Bakke <[email protected]>2020-06-14 16:24:34 +0200
commit4193095e18b602705df94e38a8d60ef1fe380e49 (patch)
tree2500f31bcfae9b4cb5a23d633395f6892a7bd8a7 /gnu/packages/cups.scm
parenta48a3f0640d76cb5e5945557c9aae6dabce39d93 (diff)
parente88745a655b220b4047f7db5175c828ef9c33e11 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index c705bbc514..d83211ede2 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -125,12 +125,6 @@
(("/usr/local/lib/cups/filter")
(string-append out "/lib/cups/filter")))
#t)))
- (add-after 'unpack 'patch-for-poppler
- (lambda _
- (substitute* "filter/pdf.cxx"
- (("GooString \\*field_name;" m)
- (string-append "const " m)))
- #t))
(add-after 'install 'wrap-filters
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Some filters expect to find 'gs' in $PATH. We cannot
@@ -250,7 +244,7 @@ device-specific programs to convert and print many types of files.")
(license license:asl2.0)))
(define-public cups
- (package (inherit cups-minimal)
+ (package/inherit cups-minimal
(name "cups")
(arguments
`(;; Three tests fail:
@@ -421,14 +415,14 @@ should only be used as part of the Guix cups-pk-helper service.")
(define-public hplip
(package
(name "hplip")
- (version "3.20.3")
+ (version "3.20.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hplip/hplip/" version
"/hplip-" version ".tar.gz"))
(sha256
(base32
- "0sh6cg7yjc11x1cm4477iaslj9n8ksghs85hqwgfbk7m5b2pw2a1"))
+ "0nj79r61fzddwwzf8kcc0qkp4y9qx46v15iarz6h6y3v91wbsjq0"))
(modules '((guix build utils)))
(patches (search-patches "hplip-remove-imageprocessor.patch"))
(snippet