summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-01-21 20:10:03 +0200
committerEfraim Flashner <[email protected]>2024-02-20 13:58:04 +0200
commit76a4ca82dd061004a703011928262036771e115e (patch)
tree0cc38369082437c444620326e1ce129f5cb246f7 /gnu/packages/crates-io.scm
parent92d9b2e0961e7edc7a8936c1a1d0af62719018e7 (diff)
gnu: rust-rcgen: Move to (gnu packages crates-tls).
* gnu/packages/crates-io.scm (rust-rcgen-0.11, rust-rcgen-0.10, rust-rcgen-0.8): Move from here ... * gnu/packages/crates-tls.scm: ... to here. Change-Id: I428c7fe7fdbed8880bd5ddfe80f68b1e92be943a
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm110
1 files changed, 0 insertions, 110 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cc0974aeda..506f1f1d75 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -53954,116 +53954,6 @@ Rust.")
(description "This package provides core APIs for Rayon.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-rcgen-0.11
- (package
- (name "rust-rcgen")
- (version "0.11.3")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "rcgen" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1iivv3xycr9mjfmp522xjqj47nsl5amlzzsfpbxpvg53984g7i2j"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Don't use a vendored botan.
- (substitute* "Cargo.toml"
- ((".*vendored.*") ""))))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-pem" ,rust-pem-3)
- ("rust-ring" ,rust-ring-0.16)
- ("rust-time" ,rust-time-0.3)
- ("rust-x509-parser" ,rust-x509-parser-0.15)
- ("rust-yasna" ,rust-yasna-0.5)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs
- (("rust-botan" ,rust-botan-0.10)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-rsa" ,rust-rsa-0.9)
- ("rust-rustls-webpki" ,rust-rustls-webpki-0.101)
- ("rust-x509-parser" ,rust-x509-parser-0.15))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list botan openssl))
- (home-page "https://github.com/rustls/rcgen")
- (synopsis "Rust X.509 certificate generator")
- (description "Rust X.509 certificate generator.")
- (license (list license:expat license:asl2.0))))
-
-(define-public rust-rcgen-0.10
- (package
- (inherit rust-rcgen-0.11)
- (name "rust-rcgen")
- (version "0.10.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "rcgen" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0nvqgr697xzdzaavkcwcl59kxw7xfx9zdhdzx49fm3gkwbpq9gpz"))
- (snippet
- #~(begin (use-modules (guix build utils))
- ;; Don't use a vendored botan.
- (substitute* "Cargo.toml"
- ((".*vendored.*") ""))))))
- (arguments
- `(#:cargo-inputs (("rust-pem" ,rust-pem-1)
- ("rust-ring" ,rust-ring-0.16)
- ("rust-time" ,rust-time-0.3)
- ("rust-x509-parser" ,rust-x509-parser-0.14)
- ("rust-yasna" ,rust-yasna-0.5)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs (("rust-botan" ,rust-botan-0.8)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-rsa" ,rust-rsa-0.6)
- ("rust-webpki" ,rust-webpki-0.22)
- ("rust-x509-parser" ,rust-x509-parser-0.14))))))
-
-(define-public rust-rcgen-0.8
- (package
- (inherit rust-rcgen-0.11)
- (name "rust-rcgen")
- (version "0.8.14")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "rcgen" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "19qvlcz8kl046q85xa40p3xg7l78jganj83hdbawjhs17x0d24ar"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Don't use a vendored botan.
- (substitute* "Cargo.toml"
- ((".*vendored.*") ""))))))
- (arguments
- `(#:cargo-test-flags
- '("--release" "--"
- "--skip=tests::test_dt_to_generalized"
- "--skip=tests::test_dt_utc_strip_nanos")
- #:cargo-inputs
- (("rust-chrono" ,rust-chrono-0.4)
- ("rust-pem" ,rust-pem-1)
- ("rust-ring" ,rust-ring-0.16)
- ("rust-x509-parser" ,rust-x509-parser-0.12)
- ("rust-yasna" ,rust-yasna-0.4)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs
- (("rust-botan" ,rust-botan-0.8)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-rsa" ,rust-rsa-0.5)
- ("rust-webpki" ,rust-webpki-0.22)
- ("rust-x509-parser" ,rust-x509-parser-0.12))))))
-
(define-public rust-rctree-0.5
(package
(name "rust-rctree")