summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-graphics.scm
diff options
context:
space:
mode:
authorHerman Rimm <[email protected]>2024-12-24 11:11:50 +0100
committerEfraim Flashner <[email protected]>2025-01-06 12:16:24 +0200
commitc865889938b5c91a2c4243e3fdf2a2f054754fbe (patch)
tree9d22007aab5cf01ba8ec31add6bc737dd3a64889 /gnu/packages/crates-graphics.scm
parentcd06e8258105e81c33e30ef2d79e750d6239bb5b (diff)
gnu: rust-xkb-0.3: Order alphabetically.
* gnu/packages/crates-graphics.scm (rust-xkb-0.3): Order. Change-Id: Id856a8fe8d72e019039bba04c2775f6e5920d977 Signed-off-by: Efraim Flashner <[email protected]>
Diffstat (limited to 'gnu/packages/crates-graphics.scm')
-rw-r--r--gnu/packages/crates-graphics.scm52
1 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 738a24e887..49b33d2354 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -6740,6 +6740,32 @@ platform-specific getters provided by winit, or another library.")
#:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.3))))))
+(define-public rust-xkb-0.3
+ (package
+ (name "rust-xkb")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "xkb" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "03rfx8n3pajc95riksnshh3aqm8dqij2iis5icl88pa6ylk9x0gj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-xcb" ,rust-xcb-1)
+ ("rust-xkbcommon-sys" ,rust-xkbcommon-sys-1))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list clang libxkbcommon-1.5 mesa))
+ (home-page "https://github.com/meh/rust-xkb")
+ (synopsis "Rusty wrapper around libxkbcommon")
+ (description "This package provides Rusty wrapper around libxkbcommon.")
+ (license license:wtfpl2)))
+
(define-public rust-xkbcommon-0.7
(package
(name "rust-xkbcommon")
@@ -6847,32 +6873,6 @@ for @code{libxkbcommon}.")
(description "This package provides bindings to libxkbcommon.")
(license license:wtfpl2)))
-(define-public rust-xkb-0.3
- (package
- (name "rust-xkb")
- (version "0.3.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "xkb" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "03rfx8n3pajc95riksnshh3aqm8dqij2iis5icl88pa6ylk9x0gj"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-1)
- ("rust-libc" ,rust-libc-0.2)
- ("rust-xcb" ,rust-xcb-1)
- ("rust-xkbcommon-sys" ,rust-xkbcommon-sys-1))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list clang libxkbcommon-1.5 mesa))
- (home-page "https://github.com/meh/rust-xkb")
- (synopsis "Rusty wrapper around libxkbcommon")
- (description "This package provides Rusty wrapper around libxkbcommon.")
- (license license:wtfpl2)))
-
(define-public rust-xkeysym-0.2
(package
(name "rust-xkeysym")