summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-compression.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-26 22:13:45 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:19:37 +0200
commitf571b76bae1e45c2d2c919b7abe65f2d27f6819e (patch)
tree20d6f939d388f0e2011c38128ee4cbf8274e6eb3 /gnu/packages/crates-compression.scm
parent50b6074fe265691b14040a63b04f7811b0eb839b (diff)
gnu: rust-ruzstd: Move to (gnu packages crates-compression).
* gnu/packages/crates-io.scm (rust-ruzstd-0.7, rust-ruzstd-0.5, rust-ruzstd-0.4): Move from here ... * gnu/packages/crates-compression.scm: ... to here. Change-Id: I999a71a5985df1775f47fc5c810fe7fa38a9cbd2
Diffstat (limited to 'gnu/packages/crates-compression.scm')
-rw-r--r--gnu/packages/crates-compression.scm89
1 files changed, 89 insertions, 0 deletions
diff --git a/gnu/packages/crates-compression.scm b/gnu/packages/crates-compression.scm
index e218770bec..3b77158640 100644
--- a/gnu/packages/crates-compression.scm
+++ b/gnu/packages/crates-compression.scm
@@ -847,6 +847,95 @@ algorithm and related formats (ZLIB, GZIP).")
#:cargo-development-inputs
(("rust-libflate" ,rust-libflate-1))))))
+(define-public rust-ruzstd-0.7
+ (package
+ (name "rust-ruzstd")
+ (version "0.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ruzstd" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "17z83lw00pd3190yvdk2lksdi7my6wc0psgg07is6gf7pyb2kl7s"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ;missing data files
+ #:cargo-inputs
+ (("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
+ ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
+ ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
+ ("rust-twox-hash" ,rust-twox-hash-1))
+ #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.5)
+ ("rust-rand" ,rust-rand-0.8))))
+ (home-page "https://github.com/KillingSpark/zstd-rs")
+ (synopsis "Decoder for the zstd compression format")
+ (description
+ "This package provides a decoder for the zstd compression format.")
+ (license license:expat)))
+
+(define-public rust-ruzstd-0.5
+ (package
+ (inherit rust-ruzstd-0.7)
+ (name "rust-ruzstd")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ruzstd" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0ga8jciw7ka3mxrzl39skmsbdslajghzglcil10g0z4rh65fpi2q"))))
+ (arguments
+ `(#:cargo-test-flags
+ '("--release" "--"
+ ;; not all files included
+ "--skip=tests::decode_corpus::test_decode_corpus_files"
+ "--skip=tests::dict_test::test_dict_decoding"
+ "--skip=tests::fuzz_regressions::test_all_artifacts"
+ "--skip=tests::test_block_header_reading"
+ "--skip=tests::test_decode_from_to"
+ "--skip=tests::test_frame_decoder"
+ "--skip=tests::test_frame_header_reading"
+ "--skip=tests::test_specific_file"
+ "--skip=tests::test_streaming")
+ #:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-derive-more" ,rust-derive-more-0.99)
+ ("rust-twox-hash" ,rust-twox-hash-1))
+ #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.3)
+ ("rust-rand" ,rust-rand-0.8))))))
+
+(define-public rust-ruzstd-0.4
+ (package
+ (inherit rust-ruzstd-0.5)
+ (name "rust-ruzstd")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ruzstd" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1p4ghqzkq36dy1x1ijnk7jmml4wi3v9bkfzlbm2hsnkiz6wglgxc"))))
+ (arguments
+ `(#:cargo-test-flags
+ '("--release" "--"
+ ;; not all files included
+ "--skip=tests::decode_corpus::test_decode_corpus_files"
+ "--skip=tests::dict_test::test_dict_decoding"
+ "--skip=tests::fuzz_regressions::test_all_artifacts"
+ "--skip=tests::test_block_header_reading"
+ "--skip=tests::test_decode_from_to"
+ "--skip=tests::test_frame_decoder"
+ "--skip=tests::test_frame_header_reading"
+ "--skip=tests::test_specific_file"
+ "--skip=tests::test_streaming")
+ #:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-thiserror-core" ,rust-thiserror-core-1)
+ ("rust-twox-hash" ,rust-twox-hash-1))
+ #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.3)
+ ("rust-rand" ,rust-rand-0.8))))))
+
(define-public rust-sevenz-rust-0.5
(package
(name "rust-sevenz-rust")