summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <[email protected]>2021-12-27 19:12:52 +0100
committerHartmut Goebel <[email protected]>2022-01-15 21:42:14 +0100
commitfab871ae7a51f0e705eb4cc8ffffe1a0822e259f (patch)
tree193436b0ae9c2e1b0f5afa792144c920d8742e5f
parent94f8ba37cc3eff71809bd197378d075e33a9945c (diff)
build/python: Improve error output in sanity check.
Instead of printing the "str()" representation of the excaption, print the "repr()" representation. This will print the name of the exception and thus ease understanding the actual error.
-rw-r--r--gnu/packages/aux-files/python/sanity-check.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/aux-files/python/sanity-check.py b/gnu/packages/aux-files/python/sanity-check.py
index a84f8f03c0..182133bb3d 100644
--- a/gnu/packages/aux-files/python/sanity-check.py
+++ b/gnu/packages/aux-files/python/sanity-check.py
@@ -44,7 +44,7 @@ for dist in ws:
pkg_resources.require(req)
print('OK')
except Exception as e:
- print('ERROR:', req, e)
+ print('ERROR:', req, repr(e))
ret = 1
continue