summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <[email protected]>2022-04-24 11:12:48 +0000
committerEfraim Flashner <[email protected]>2022-04-24 16:02:01 +0300
commit9cf812f60104042b46f58faa2cce2d549f2cdb68 (patch)
tree89cb74b0f16d7dbc9c7893623aba5c304beccd9b
parent0a815a08d384af18051378762edd2f71e6ce66fa (diff)
gnu: stockfish: Update to 15.
* gnu/packages/games.scm (stockfish): Update to 15. Signed-off-by: Efraim Flashner <[email protected]>
-rw-r--r--gnu/packages/games.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ff2b3199e0..7aad3c00d0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -59,7 +59,7 @@
;;; Copyright © 2020 Tomás Ortín Fernández <[email protected]>
;;; Copyright © 2021 Olivier Rojon <[email protected]>
;;; Copyright © 2021 Stefan Reichör <[email protected]>
-;;; Copyright © 2021 Greg Hogan <[email protected]>
+;;; Copyright © 2021, 2022 Greg Hogan <[email protected]>
;;; Copyright © 2021 David Pflug <[email protected]>
;;; Copyright © 2021, 2022 Felix Gruber <[email protected]>
;;; Copyright © 2021 Solene Rapenne <[email protected]>
@@ -11957,10 +11957,10 @@ etc. You can also play games on FICS or against an engine.")
(license license:gpl2+)))
(define-public stockfish
- (let ((neural-network-revision "13406b1dcbe0")) ; also update hash below
+ (let ((neural-network-revision "6877cd24400e")) ; also update hash below
(package
(name "stockfish")
- (version "14.1")
+ (version "15")
(source
(origin
(method git-fetch)
@@ -11969,7 +11969,7 @@ etc. You can also play games on FICS or against an engine.")
(commit (string-append "sf_" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0apqqcgpcflm3c6mcl13ln2y04f6zksnljmk4ys7naf7xk4vdgkd"))))
+ (base32 "1v19v6qhwbf31wpc3qcih4dvqxwqkh0p426skgjin6ags31hkbmh"))))
(build-system gnu-build-system)
(inputs
`(("neural-network"
@@ -11979,7 +11979,7 @@ etc. You can also play games on FICS or against an engine.")
neural-network-revision ".nnue"))
(sha256
(base32
- "0vr3hcmlqqm74pn7hc54gmfs9drqvgc53nh7bvy6v8z0rcfnnh0k"))))))
+ "1qyna598c0v7gdpycc6kpl12h5a2wa50dqray6gv208f80jcsxv8"))))))
(arguments
`(#:tests? #f
#:make-flags (list "-C" "src"