summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomasz Jeneralczyk <[email protected]>2022-08-14 14:46:21 +0200
committerLudovic Courtès <[email protected]>2022-08-30 00:40:05 +0200
commit5920196e47343403ea43f49c19b637fe62a11220 (patch)
treeceaacad350d8d9952633adf8367208b45a9984b1
parent619af9f3076fbfb29f4c44e38a74bc1c5808624c (diff)
gnu: opencv: Build Python bindings.
* gnu/packages/image-processing.scm (opencv)[arguments]: Change variable. Signed-off-by: Ludovic Courtès <[email protected]>
-rw-r--r--gnu/packages/image-processing.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 3dfe086af8..0225f72651 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <[email protected]>
;;; Copyright © 2021 Ivan Gankevich <[email protected]>
;;; Copyright © 2022 Maxim Cournoyer <[email protected]>
+;;; Copyright © 2022 Tomasz Jeneralczyk <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -511,6 +512,9 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
;; DISPATCH is the list of optional dispatches.
"-DCPU_BASELINE=SSE2"
+ ;; Build Python bindings.
+ "-DBUILD_opencv_python3=ON"
+
,@(match (%current-system)
("x86_64-linux"
'("-DCPU_DISPATCH=NEON;VFPV3;FP16;SSE;SSE2;SSE3;SSSE3;SSE4_1;SSE4_2;POPCNT;AVX;FP16;AVX2;FMA3;AVX_512F;AVX512_SKX"