summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <[email protected]>2022-03-11 01:15:16 +0100
committerLudovic Courtès <[email protected]>2022-03-16 15:48:52 +0100
commit4ba792fa157753ebbc1ecb49740930d83db8ea2a (patch)
treeaff1b9d1486ca2885d898e33ea7c5e16f1520d5b
parent47960b55268220ca1cb7d2fed41c53873181d816 (diff)
gnu: python-gitlab: update to 3.2.0
* gnu/packages/python-web.scm (python-gitlab): Update to 3.2.0 Signed-off-by: Denis 'GNUtoo' Carikli <[email protected]> Signed-off-by: Ludovic Courtès <[email protected]>
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 466d9782ca..9c2a48166a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2021 jgart <[email protected]>
;;; Copyright © 2021 Alice Brenon <[email protected]>
;;; Copyright © 2022 John Kehayias <[email protected]>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4910,21 +4911,18 @@ is part of the Weblate translation platform.")
(define-public python-gitlab
(package
(name "python-gitlab")
- (version "1.15.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "python-gitlab" version))
- (sha256
- (base32
- "0zl6kz8v8cg1bcy2r78b2snb0lpw0b573gdx2x1ps0nhsh75l4j5"))))
+ (version "3.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-gitlab" version))
+ (sha256
+ (base32
+ "1gi4lp2g4k99zqcx2bgqx940bpmpbc1w9qkl5gy33hpy148yhvlg"))))
(build-system python-build-system)
- (propagated-inputs
- (list python-requests python-six))
- (native-inputs
- (list python-httmock python-mock))
- (home-page
- "https://github.com/python-gitlab/python-gitlab")
+ (arguments
+ `(#:tests? #f)) ;tests require network access
+ (propagated-inputs (list python-requests python-requests-toolbelt))
+ (home-page "https://github.com/python-gitlab/python-gitlab")
(synopsis "Interact with GitLab API")
(description "This package provides an extended library for interacting
with GitLab instances through their API.")