summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2023-01-14 22:16:01 +0200
committerEfraim Flashner <[email protected]>2023-01-14 22:16:01 +0200
commit1bf6950e0ca3de2c87cf543ed6a336f0ca7004c0 (patch)
treee3adf4e7ec389b396c3cd9e2b03f566b1b1ef961
parentcfe0ef1a65f0c2eb4df2275e87ad415c7838b9a5 (diff)
gnu: rust-markup5ever-0.10: Update to 0.10.1.
* gnu/packages/crates-io.scm (rust-markup5ever-0.10): Update to 0.10.1. [cargo-inputs]: Remove rust-serde-1, rust-serde-derive-1, rust-serde-json-1. Sort alphabetically.
-rw-r--r--gnu/packages/crates-io.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 56388b2ebc..59c7a14523 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32211,7 +32211,7 @@ algorithms. It supports CBC block cipher mode, PKCS5 padding and 64, 128,
(define-public rust-markup5ever-0.10
(package
(name "rust-markup5ever")
- (version "0.10.0")
+ (version "0.10.1")
(source
(origin
(method url-fetch)
@@ -32220,19 +32220,16 @@ algorithms. It supports CBC block cipher mode, PKCS5 padding and 64, 128,
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1aqxl1lsc8s6ycsw5ibwynadnb9qpiab4ggwgdq9pjlnjdk8vqxa"))))
+ "1zf8iq2czd6kz99fjs3pgf5c17lfz75ds31khkfiqbc50gxl0kx2"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-log" ,rust-log-0.4)
("rust-phf" ,rust-phf-0.8)
- ("rust-string-cache" ,rust-string-cache-0.8)
- ("rust-tendril" ,rust-tendril-0.4)
("rust-phf-codegen" ,rust-phf-codegen-0.8)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-derive" ,rust-serde-derive-1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-string-cache-codegen" ,rust-string-cache-codegen-0.5))))
+ ("rust-string-cache" ,rust-string-cache-0.8)
+ ("rust-string-cache-codegen" ,rust-string-cache-codegen-0.5)
+ ("rust-tendril" ,rust-tendril-0.4))))
(home-page "https://github.com/servo/html5ever")
(synopsis "Common code for xml5ever and html5ever")
(description