From e6301fb76d0a8d931ece2e18d197e3c2cc53fc6c Mon Sep 17 00:00:00 2001
From: Ludovic Courtès <ludo@gnu.org>
Date: Tue, 26 Mar 2019 10:22:15 +0100
Subject: packages: Adjust to new calling convention for "thunked" fields.

Fixes <https://bugs.gnu.org/34995>.

This is a followup to abd4d6b33dba4de228e90ad15a8efb456fcf7b6e.

* guix/packages.scm (package->bag): Adjust calls to INPUTS,
PROPAGATED-INPUTS, NATIVE-INPUTS, and ARGS, passing them SELF as an
argument.
* gnu/packages/gnucash.scm (gnucash)[arguments]: Use (package-inputs
this-record) intead of (inputs).
* gnu/packages/version-control.scm (git)[arguments]: Likewise.
---
 gnu/packages/gnucash.scm         | 5 +++--
 gnu/packages/version-control.scm | 5 +++--
 2 files changed, 6 insertions(+), 4 deletions(-)

(limited to 'gnu')

diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 2207dd3fae..84b244cdd9 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -27,6 +27,7 @@ (define-module (gnu packages gnucash)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
+  #:use-module ((guix records) #:select (this-record))
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
@@ -165,14 +166,14 @@ (define-public gnucash
                                         ,@(transitive-input-references
                                            'inputs
                                            (map (lambda (l)
-                                                  (assoc l (inputs)))
+                                                  (assoc l (package-inputs this-record)))
                                                 '("perl-finance-quote"
                                                   "perl-date-manip"))))
                                        (list
                                         ,@(transitive-input-references
                                            'inputs
                                            (map (lambda (l)
-                                                  (assoc l (inputs)))
+                                                  (assoc l (package-inputs this-record)))
                                                 '("perl-finance-quote")))))))))
                        '("gnucash"
                          "gnc-fq-check"
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9a6f96ce14..fe9b64ba5c 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -51,6 +51,7 @@ (define-module (gnu packages version-control)
   #:use-module (guix build-system haskell)
   #:use-module (guix build-system python)
   #:use-module (guix build-system trivial)
+  #:use-module ((guix records) #:select (this-record))
   #:use-module (gnu packages apr)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages documentation)
@@ -408,7 +409,7 @@ (define-public git
                          ,@(transitive-input-references
                             'inputs
                             (map (lambda (l)
-                                   (assoc l (inputs)))
+                                   (assoc l (package-inputs this-record)))
                                  '("perl-authen-sasl"
                                    "perl-net-smtp-ssl"
                                    "perl-io-socket-ssl")))))))
@@ -421,7 +422,7 @@ (define-public git
                          ,@(transitive-input-references
                             'inputs
                             (map (lambda (l)
-                                   (assoc l (inputs)))
+                                   (assoc l (package-inputs this-record)))
                                  '("perl-cgi")))))))
 
               ;; Tell 'git-submodule' where Perl is.
-- 
cgit v1.2.3