From db7f74d2eb4878c0a9ed8bb33853090752277370 Mon Sep 17 00:00:00 2001
From: Jakub Kądziołka <kuba@kadziolka.net>
Date: Wed, 17 Jun 2020 02:10:52 +0200
Subject: gnu: lcalc: Don't rename the include directory.

Sage no longer renames the directory, so we shouldn't either.

* gnu/packages/sagemath.scm (lcalc)[arguments]: Remove a substitution from
  the prepare-build phase.
---
 gnu/packages/sagemath.scm | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

(limited to 'gnu')

diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index c94020f13e..8c837fdaeb 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -368,10 +368,7 @@ (define-public lcalc
              (let ((out (assoc-ref outputs "out")))
                (substitute* "Makefile"
                  (("^INSTALL_DIR= /usr/local")
-                  (string-append "INSTALL_DIR=" out))
-                 ;; Sage renames the include directory, so we do it also.
-                 (("include/Lfunction")
-                  "include/libLfunction")))
+                  (string-append "INSTALL_DIR=" out))))
              #t))
          (add-before 'install 'make-output-dirs
            (lambda* (#:key outputs #:allow-other-keys)
-- 
cgit v1.2.3