From a430a3501a6d3a565cb78e04a8dbb3ab846ec5fc Mon Sep 17 00:00:00 2001
From: Timothy Sample <samplet@ngyro.com>
Date: Sun, 12 May 2019 09:36:38 -0400
Subject: gnu: gdm: Fix configuration file discovery.

The configuration file loading code moved to a new file in version 2.28.

* gnu/package/gnome.scm (gdm)[arguments]: Change the pre-configure phase
to patch configuration file discovery into the 'gdm-settings.c' file.
---
 gnu/packages/gnome.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'gnu')

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 44ae693be0..09984717cc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5655,8 +5655,8 @@ (define-public gdm
                                 "(self, \"" name "\","
                                 "g_getenv (\"" name "\"));\n"))
                              propagate)))))
-            ;; Look for custom GDM conf in /run/current-system.
-            (substitute* '("common/gdm-settings-desktop-backend.c")
+            ;; Find the configuration file using an environment variable.
+            (substitute* '("common/gdm-settings.c")
               (("GDM_CUSTOM_CONF")
                (string-append "(g_getenv(\"GDM_CUSTOM_CONF\") != NULL"
                               " ? g_getenv(\"GDM_CUSTOM_CONF\")"
-- 
cgit v1.2.3